There is a lot of duplicate code between them.
We should probably reuse the code, and just add
another field to UnwindFunctor to give it a "search"
mode that doesn't copyCalleeSaves and also unwinds past
VM entry frames.
Change of plans. I'm keeping two separate functors and just
writing a function to be shared between them.
Created attachment 261472 [details]
Comment on attachment 261472 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=261472&action=review
Looks good. r=me
> + Abstract some common code between GetCatchHandlerFunctor and UnwindFunctor
Do you mean "Extract" instead of "Abstract"? Or perhaps "Refactor common code out of Get...".