Bug 149129 - [ES6] Add more fine-grained APIs and additional hooks to control module loader from WebCore
Summary: [ES6] Add more fine-grained APIs and additional hooks to control module loade...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Yusuke Suzuki
URL:
Keywords:
Depends on:
Blocks: 147340 148897
  Show dependency treegraph
 
Reported: 2015-09-14 14:34 PDT by Yusuke Suzuki
Modified: 2015-09-17 15:26 PDT (History)
1 user (show)

See Also:


Attachments
Patch (28.82 KB, patch)
2015-09-14 15:11 PDT, Yusuke Suzuki
no flags Details | Formatted Diff | Diff
Patch (29.55 KB, patch)
2015-09-16 21:57 PDT, Yusuke Suzuki
sbarati: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yusuke Suzuki 2015-09-14 14:34:21 PDT
[ES6] Add more fine-grained APIs and additional hooks to control module loader from WebCore
Comment 1 Yusuke Suzuki 2015-09-14 15:11:41 PDT
Created attachment 261135 [details]
Patch
Comment 2 Yusuke Suzuki 2015-09-16 21:57:56 PDT
Created attachment 261366 [details]
Patch

More clean up
Comment 3 Saam Barati 2015-09-17 13:19:10 PDT
Comment on attachment 261366 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=261366&action=review

r=me with comment

> Source/JavaScriptCore/builtins/ModuleLoaderObject.js:541
> +function prepareModuleGraph(moduleName, referrer)

I think we need a better name for this, maybe: "loadAndExecuteModule" or "loadAndEvaluateModule"?
Or something that indicates execution better than "prepare". I don't think "graph" is needed in the name.
Comment 4 Yusuke Suzuki 2015-09-17 13:44:47 PDT
Comment on attachment 261366 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=261366&action=review

Thank you for your review!

>> Source/JavaScriptCore/builtins/ModuleLoaderObject.js:541
>> +function prepareModuleGraph(moduleName, referrer)
> 
> I think we need a better name for this, maybe: "loadAndExecuteModule" or "loadAndEvaluateModule"?
> Or something that indicates execution better than "prepare". I don't think "graph" is needed in the name.

After discussing with you on IRC, I'll rename APIs.
prepareModuleGraph => loadModule, loadModuleGraph => loadAndEvaluateModule, and linkAndEvaluateModuleGraph => linkAndEvaluateModule
Comment 5 Yusuke Suzuki 2015-09-17 15:26:32 PDT
Committed r189941: <http://trac.webkit.org/changeset/189941>