Bug 149028 - ModuleProgramExecutable should provide CodeBlock to ScriptExecutable::forEachCodeBlock
Summary: ModuleProgramExecutable should provide CodeBlock to ScriptExecutable::forEach...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Yusuke Suzuki
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-09 19:06 PDT by Yusuke Suzuki
Modified: 2015-09-10 10:11 PDT (History)
6 users (show)

See Also:


Attachments
Patch (2.22 KB, patch)
2015-09-09 19:07 PDT, Yusuke Suzuki
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yusuke Suzuki 2015-09-09 19:06:47 PDT
ModuleProgramExecutable should provide CodeBlock to ScriptExecutable::forEachCodeBlock
Comment 1 Yusuke Suzuki 2015-09-09 19:07:42 PDT
Created attachment 260903 [details]
Patch
Comment 2 Yusuke Suzuki 2015-09-09 19:11:01 PDT
I searched with FunctionExecutableType and ensured that ModuleProgramExecutableType is handled in the other place.
Comment 3 Yusuke Suzuki 2015-09-09 21:18:28 PDT
Comment on attachment 260903 [details]
Patch

I'll merge this to https://bugs.webkit.org/show_bug.cgi?id=149027
Comment 4 Yusuke Suzuki 2015-09-09 21:18:50 PDT

*** This bug has been marked as a duplicate of bug 149027 ***
Comment 5 Yusuke Suzuki 2015-09-09 21:34:17 PDT
This is also difficult to reproduce this crash stably, so in the meantime, we
Comment 6 Yusuke Suzuki 2015-09-09 21:41:59 PDT
I attempted to merge this and https://bugs.webkit.org/show_bug.cgi?id=149027 with GC related tests, but they are difficult to reproduce with the tests.
So in the meantime, separate these patches.
Comment 7 Yusuke Suzuki 2015-09-09 21:43:23 PDT
These faults are figured out during the ES6 Module WebCore integration.
Comment 8 Michael Saboff 2015-09-10 06:09:22 PDT
Comment on attachment 260903 [details]
Patch

r=me
Comment 9 Yusuke Suzuki 2015-09-10 09:25:10 PDT
Comment on attachment 260903 [details]
Patch

Thank you!
Comment 10 WebKit Commit Bot 2015-09-10 10:11:45 PDT
Comment on attachment 260903 [details]
Patch

Clearing flags on attachment: 260903

Committed r189571: <http://trac.webkit.org/changeset/189571>
Comment 11 WebKit Commit Bot 2015-09-10 10:11:51 PDT
All reviewed patches have been landed.  Closing bug.