Bug 148975 - Web Inspector: Dev tools tab close button doesn't match position of main web page tabs close button
Summary: Web Inspector: Dev tools tab close button doesn't match position of main web ...
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All OS X 10.10
: P2 Trivial
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2015-09-08 13:30 PDT by Daniel Compton
Modified: 2015-09-08 13:51 PDT (History)
7 users (show)

See Also:


Attachments
Smaller width dev tools (24.46 KB, image/png)
2015-09-08 13:30 PDT, Daniel Compton
no flags Details
Larger width devotees (28.44 KB, image/png)
2015-09-08 13:30 PDT, Daniel Compton
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Compton 2015-09-08 13:30:18 PDT
Created attachment 260787 [details]
Smaller width dev tools

When the dev tools window has a small width, the tab close button replaces the tab icon, rather than being a new hard left aligned icon. This is counterintuitive as everywhere else in the OS X platform, a close button is always hard left, and it is harder to click. I've attached screenshots showing the different behaviour.
Comment 1 Daniel Compton 2015-09-08 13:30:50 PDT
Created attachment 260788 [details]
Larger width devotees
Comment 2 Timothy Hatcher 2015-09-08 13:35:15 PDT
This is by design. To have the tab icon (unlike Safari) the close box needs to replace the icon when there ins't room to show both.
Comment 3 Radar WebKit Bug Importer 2015-09-08 13:38:59 PDT
<rdar://problem/22616406>
Comment 4 Daniel Compton 2015-09-08 13:48:11 PDT
Would it be possible to hide the icon or move it to the left instead then? The other thing I noticed is that because the tab names have different lengths, the close box is not even in a consistent spot for each tab.
Comment 5 Timothy Hatcher 2015-09-08 13:51:51 PDT
Moving the icon would cause a visual change as you resize that would me a caring jump to the user. Since the close button is not used regularly and is only on hover, this was the best design we could come up with while keeping the icons in the tab.