Bug 14861 - run-webkit-tests should link to Mac crash logs in results.html
Summary: run-webkit-tests should link to Mac crash logs in results.html
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh All
: P2 Enhancement
Assignee: Adam Roben (:aroben)
URL:
Keywords:
: 30136 (view as bug list)
Depends on: 53718
Blocks: 32091 33230
  Show dependency treegraph
 
Reported: 2007-08-02 01:16 PDT by Adam Roben (:aroben)
Modified: 2011-02-04 13:42 PST (History)
4 users (show)

See Also:


Attachments
Patch with ChangeLog (6.06 KB, patch)
2007-08-02 01:28 PDT, Adam Roben (:aroben)
no flags Details | Formatted Diff | Diff
Link to Mac crash logs from results.html (2.74 KB, patch)
2011-02-04 08:46 PST, Adam Roben (:aroben)
ddkilzer: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2007-08-02 01:16:48 PDT
patch coming
Comment 1 Adam Roben (:aroben) 2007-08-02 01:28:44 PDT
Created attachment 15803 [details]
Patch with ChangeLog
Comment 2 Mark Rowe (bdash) 2007-08-02 01:34:08 PDT
Comment on attachment 15803 [details]
Patch with ChangeLog

I think it would be preferable to not blow away crash logs permanently.  Perhaps they could be renamed in some way such that we don't see them in the future, or we could only look at the newest log?  Having the crash logs around long-term can be useful for various purposes.
Comment 3 Eric Seidel (no email) 2009-10-28 09:45:30 PDT
*** Bug 30136 has been marked as a duplicate of this bug. ***
Comment 4 Adam Roben (:aroben) 2011-02-03 14:29:44 PST
Once bug 53718 is fixed, all that needs to be done is to add a case for Mac to the captureSavedCrashLog function.
Comment 5 Eric Seidel (no email) 2011-02-03 17:01:00 PST
Chromium already does something like this for their builds under NRWT (or at least I think they do).

Once this is added, the commit-queue will automatically include crash reports when reporting flaky crash tests. :)
Comment 6 Adam Roben (:aroben) 2011-02-04 08:46:23 PST
Created attachment 81224 [details]
Link to Mac crash logs from results.html
Comment 7 David Kilzer (:ddkilzer) 2011-02-04 08:51:36 PST
Comment on attachment 81224 [details]
Link to Mac crash logs from results.html

View in context: https://bugs.webkit.org/attachment.cgi?id=81224&action=review

r=me!

> Tools/Scripts/old-run-webkit-tests:1763
> +        if (my @reportCrashPIDs = sort map { /^\s*(\d+)/; $1 } grep { /ReportCrash/ } `ps x`) {

Nit:  I prefer to use "/bin/ps" instead of just "ps", but it only matters if more than one 'ps' is installed in the path (e.g., by an attacker or MacPorts).
Comment 8 Adam Roben (:aroben) 2011-02-04 09:31:57 PST
Committed r77633: <http://trac.webkit.org/changeset/77633>
Comment 9 Eric Seidel (no email) 2011-02-04 13:30:29 PST
Comment on attachment 81224 [details]
Link to Mac crash logs from results.html

View in context: https://bugs.webkit.org/attachment.cgi?id=81224&action=review

> Tools/Scripts/old-run-webkit-tests:1759
> +        $glob = File::Spec->catfile("~", "Library", "Logs", "CrashReporter", $dumpToolName . "_*.crash");

The location is OS version dependent.  So I think we'll need to tweak this for Leopard and Tiger (and possibly Lion).
Comment 10 Adam Roben (:aroben) 2011-02-04 13:42:17 PST
(In reply to comment #9)
> (From update of attachment 81224 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=81224&action=review
> 
> > Tools/Scripts/old-run-webkit-tests:1759
> > +        $glob = File::Spec->catfile("~", "Library", "Logs", "CrashReporter", $dumpToolName . "_*.crash");
> 
> The location is OS version dependent.  So I think we'll need to tweak this for Leopard and Tiger (and possibly Lion).

Be my guest! I just did what works on SnowLeopard, as I didn't have Leopard and Tiger available for testing.