Bug 148471 - [EFL] REGRESSION: 50+ layout tests crash
Summary: [EFL] REGRESSION: 50+ layout tests crash
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Csaba Osztrogonác
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-26 01:44 PDT by Csaba Osztrogonác
Modified: 2015-08-27 02:16 PDT (History)
7 users (show)

See Also:


Attachments
It fixed the crashes for me locally. (1.33 KB, patch)
2015-08-27 01:49 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2015-08-26 01:44:12 PDT
https://build.webkit.org/builders/EFL%20Linux%2064-bit%20Release%20WK2/builds/24073

https://trac.webkit.org/changeset/188948 fixed a regression caused by
https://trac.webkit.org/changeset/188828, but it seems it is an older bug,
because there were the same failures before r188828:
https://build.webkit.org/builders/EFL%20Linux%2064-bit%20Release%20WK2/builds/24007

Last known good revision: https://trac.webkit.org/changeset/188691
...
build failure during this period :-(
...
first failure: https://trac.webkit.org/changeset/188751 (fixed the build after r188718)

(https://trac.webkit.org/changeset/188738 fixed the build failure after r188693)
Comment 1 Csaba Osztrogonác 2015-08-27 01:47:19 PDT
GTK already fixed these crashes in
https://trac.webkit.org/changeset/188980

I think we need this fix after https://trac.webkit.org/changeset/188228
Comment 2 Csaba Osztrogonác 2015-08-27 01:49:04 PDT
Created attachment 260048 [details]
It fixed the crashes for me locally.
Comment 3 Gyuyoung Kim 2015-08-27 01:51:43 PDT
Comment on attachment 260048 [details]
It fixed the crashes for me locally.

Thank you for fix !
Comment 4 Csaba Osztrogonác 2015-08-27 02:16:20 PDT
Comment on attachment 260048 [details]
It fixed the crashes for me locally.

Clearing flags on attachment: 260048

Committed r189016: <http://trac.webkit.org/changeset/189016>
Comment 5 Csaba Osztrogonác 2015-08-27 02:16:30 PDT
All reviewed patches have been landed.  Closing bug.