Unify code paths for manually deleting all code
Created attachment 259557 [details] Patch
Attachment 259557 [details] did not pass style-queue: ERROR: Source/JavaScriptCore/runtime/VMEntryScope.cpp:60: Extra space before ( in function call [whitespace/parens] [4] ERROR: Source/JavaScriptCore/runtime/VMEntryScope.h:46: Extra space before ( in function call [whitespace/parens] [4] ERROR: Source/JavaScriptCore/runtime/VMEntryScope.h:51: Extra space before ( in function call [whitespace/parens] [4] Total errors found: 3 in 7 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 259557 [details] Patch Attachment 259557 [details] did not pass mac-wk2-ews (mac-wk2): Output: http://webkit-queues.webkit.org/results/83879 New failing tests: inspector/dom-debugger/node-removed.html
Created attachment 259569 [details] Archive of layout-test-results from ews106 for mac-mavericks-wk2 The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews. Bot: ews106 Port: mac-mavericks-wk2 Platform: Mac OS X 10.9.5
Comment on attachment 259557 [details] Patch Attachment 259557 [details] did not pass mac-ews (mac): Output: http://webkit-queues.webkit.org/results/83920 New failing tests: inspector/dom-debugger/node-removed.html
Created attachment 259570 [details] Archive of layout-test-results from ews102 for mac-mavericks The attached test failures were seen while running run-webkit-tests on the mac-ews. Bot: ews102 Port: mac-mavericks Platform: Mac OS X 10.9.5
Comment on attachment 259557 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=259557&action=review > Source/JavaScriptCore/inspector/agents/InspectorRuntimeAgent.cpp:340 > + vm.deleteAllCode(); I don't think this is correct. If we don't immediately delete all code, the type profiling code has the chance of incurring a use after free bug because the above line may deallocate all type profiler related data structures. The executing JS code may refer to these data structures and modify them.
Created attachment 259669 [details] Patch
Attachment 259669 [details] did not pass style-queue: ERROR: Source/JavaScriptCore/runtime/VMEntryScope.cpp:60: Extra space before ( in function call [whitespace/parens] [4] ERROR: Source/JavaScriptCore/runtime/VMEntryScope.h:46: Extra space before ( in function call [whitespace/parens] [4] ERROR: Source/JavaScriptCore/runtime/VMEntryScope.h:51: Extra space before ( in function call [whitespace/parens] [4] Total errors found: 3 in 8 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 259669 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=259669&action=review r=me > Source/JavaScriptCore/runtime/VM.cpp:475 > +void VM::afterVMExit(std::function<void()> callback) I wonder if there is a better name for this. Just reading this name without reading its implementation indicates to me that this is always called asynchronously.
> > Source/JavaScriptCore/runtime/VM.cpp:475 > > +void VM::afterVMExit(std::function<void()> callback) > > I wonder if there is a better name for this. Just reading this name without > reading its implementation > indicates to me that this is always called asynchronously. Switch when whenIdle.
Committed r188792: <http://trac.webkit.org/changeset/188792>
Re-opened since this is blocked by bug 148347
Committed r188846: <http://trac.webkit.org/changeset/188846>