Bug 14826 - weird layout using padding-right on inline element
Summary: weird layout using padding-right on inline element
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2007-07-31 07:27 PDT by Thierry Pierron
Modified: 2013-07-27 03:59 PDT (History)
2 users (show)

See Also:


Attachments
inline span with padding-right that cause weird layout (2.01 KB, text/html)
2007-07-31 07:29 PDT, Thierry Pierron
no flags Details
inline span with padding-right that cause weird layout (1.94 KB, text/html)
2007-07-31 07:33 PDT, Thierry Pierron
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thierry Pierron 2007-07-31 07:27:52 PDT
The example include a series of span displayed as inline element, where the padding-right property has been tweaked to make them displayed into column. It work almost well, except the first line, which is word-wrapped a little too early.

Actually, trying to find the minimal bug show case, when I remove the <input type=checkbox> tags, the layout worked as expected.
Comment 1 Thierry Pierron 2007-07-31 07:29:21 PDT
Created attachment 15757 [details]
inline span with padding-right that cause weird layout
Comment 2 Thierry Pierron 2007-07-31 07:33:41 PDT
Created attachment 15758 [details]
inline span with padding-right that cause weird layout
Comment 3 David Kilzer (:ddkilzer) 2007-07-31 07:59:19 PDT
Confirmed difference to Firefox 2.0.0.6 using a local debug build of WebKit r24792 with Safari 3 Public Beta v. 3.0.2 (522.12) on Mac OS X 10.4.10 (8R218).

This is not a regression from shipping Safari 2.0.4 (419.3) with original WebKit as it has the same issue.

The first row in the test case should have three items in it, but only has two.

Comment 4 Robert Hogan 2013-07-27 03:59:43 PDT
Bug description is a bit vague. The test case doesn't look problematic to me on ToT WebKit. Can you close if it looks fixed to you?