Bug 147879 - Backdrop-filter blur rendering issue
Summary: Backdrop-filter blur rendering issue
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.10
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-11 06:33 PDT by Mathieu HAYS
Modified: 2017-04-25 03:07 PDT (History)
2 users (show)

See Also:


Attachments
Gif demonstration of the issue (827.61 KB, image/gif)
2015-08-11 06:33 PDT, Mathieu HAYS
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mathieu HAYS 2015-08-11 06:33:41 PDT
Created attachment 258714 [details]
Gif demonstration of the issue

Hi,

Issue:
The Blur generation catches other windows into the blur generation when used in -webkit-backdrop-filter

How to reproduce:
I made a very simple example : http://mathieuhays.github.io/Backdrop-filter/

Open the inspector on a separate window.
Position it above the blurred part.
Toggle the css property -webkit-backdrop-filter off and on again.
Move the inspector out of the way.
You should see that the inspector window has been included in the blur rendering.
Comment 1 Simon Fraser (smfr) 2015-08-11 22:18:23 PDT
I can't reproduce on Yosemite. What OS, hardware and WebKit revision were you seeing this on?
Comment 2 Mathieu HAYS 2015-08-12 00:45:57 PDT
I tried on both iMac and macbook on OS X 10.10.5
Webkit version 8.0.8 (10600.8.9, r188304)

I noticed that the issue also happens when you refresh the page with the inspector focused and on top of the blurred part.

http://recordit.co/kDeQXwCb7J
Comment 3 Mathieu HAYS 2017-04-25 03:07:38 PDT
I just tested again in the latest Safari version and it's now fixed