Bug 14768 - REGRESSION: After Back button, View Source not an option in
Summary: REGRESSION: After Back button, View Source not an option in
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: History (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar, Regression
: 14850 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-07-25 17:48 PDT by Eric Leversen
Modified: 2007-08-01 10:24 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Leversen 2007-07-25 17:48:13 PDT
After clicking Back button, View Source is greyed out in EDIT menu and absent from right-click menu.

To replicate: go to google, do a search, click Back, try to view source.
Comment 1 David Kilzer (:ddkilzer) 2007-07-25 23:40:01 PDT
Confirmed with a local debug build of WebKit r24619 with Safari 3 Public Beta v. 3.0.2 (522.12) on Mac OS X 10.4.10 (8R218).

This is a regression from shipping Safari 2.0.4 (419.3) with original WebKit on 10.4.10.

Comment 2 David Kilzer (:ddkilzer) 2007-07-25 23:40:19 PDT
<rdar://problem/5361870>
Comment 3 Justin Garcia 2007-07-26 01:04:51 PDT
This is:

<rdar://problem/5258776> REGRESSION: View Source Menu is disabled after going back (missing didFinishDocumentLoad callback)

which is fixed in TOT Safari (not in WebKit though, that bug is tracked by <rdar://problem/5259339> didFinishDocumentLoad callback is not sent for (some?) cached page loads).  Since the fix was in Safari, and not WebKit, it'll be broken in nightly builds until we ship a new version of Safari.
Comment 4 Brady Eidson 2007-07-26 01:07:53 PDT
Or, alternately, it will be broken in nightlys until A - a new version of Safari with the workaround ships or B - someone fixes the WebKit end of things.
Comment 5 David Kilzer (:ddkilzer) 2007-07-26 05:08:31 PDT
Marking this as RESOLVED/INVALID because this is a Safari issue, not a WebKit issue.  (The bug is otherwise valid, and will be fixed per Comment #3 and Comment #4.)

Thanks Justin & Brady!
Comment 6 David Kilzer (:ddkilzer) 2007-08-01 10:24:31 PDT
*** Bug 14850 has been marked as a duplicate of this bug. ***