At least move FrameLoaderClientGdk, FrameGdk from the WebCore namespace into the WebKitGtk namespace and move these files from WebCore/platform/gdk to WebKit/gtk/WebCoreSupport.
make sure to update WebCore/WebCore.pro as well and list the files we want to move in the comments.
FrameGdk should not be moved, as it is a subclass of WebCore::Frame. I'd suggest FrameGdk be removed entirely (just as FrameMac/FrameWin/FrameQt were removed a few months ago).
Add the Gtk keyword, even to the curl bugs.
The first renaming is done, the next one is coming up:
WebKitGtk::FooClientGtk -> WebKit::FooClient
I think all relevant classes are in WebKit/gtk/WebCoreSupport and I don't plan to do any change to the names of these classes.