Bug 147195 - jsc-tailcall: Disable tail calls when profiler is enabled
Summary: jsc-tailcall: Disable tail calls when profiler is enabled
Status: RESOLVED DUPLICATE of bug 148661
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Basile Clement
URL:
Keywords:
Depends on: 146484
Blocks: 146477
  Show dependency treegraph
 
Reported: 2015-07-22 11:01 PDT by Basile Clement
Modified: 2015-09-04 13:15 PDT (History)
1 user (show)

See Also:


Attachments
Patch (4.40 KB, patch)
2015-08-04 11:28 PDT, Basile Clement
msaboff: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Basile Clement 2015-07-22 11:01:58 PDT
The profiler relies on having pairs of op_profile_will_call / op_profile_did_call opcodes for function calls, which is not possible with tail calls since we never return from the tail call.
So, we should temporarily disable tail calls when the profiler is enabled, until we figure out a way of handling them in the profiler.
Comment 1 Basile Clement 2015-08-04 11:28:38 PDT
Created attachment 258188 [details]
Patch
Comment 2 Michael Saboff 2015-08-04 11:59:01 PDT
Comment on attachment 258188 [details]
Patch

r=me
Comment 3 Basile Clement 2015-09-04 13:15:35 PDT

*** This bug has been marked as a duplicate of bug 148661 ***