Bug 14708 - Motion JPEG (MJPG) displays incorrectly, crashes
Summary: Motion JPEG (MJPG) displays incorrectly, crashes
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Images (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh Intel OS X 10.4
: P4 Critical
Assignee: Nobody
URL: http://discord.itg.uiuc.edu/testing/M...
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-21 22:01 PDT by Chas Conway
Modified: 2007-07-22 08:38 PDT (History)
0 users

See Also:


Attachments
Crashlog from Apple Safari 3 beta (18.84 KB, text/plain)
2007-07-22 07:49 PDT, Chas Conway
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chas Conway 2007-07-21 22:01:49 PDT
The Motion JPEG file/stream coming from our Axis video server (www.axis.com) displays incorrectly and almost always ends up crashing Safari/Webkit either soon after loading or upon unloading the page (e.g. visiting another url).

Worked in Safari up to the public beta of 3.0 and also seems to crash the latest Webkit nightly.  The video image tended to appear to shake side to side and vary dramatically in brightness.  The demo page listed may show all-black video as unfortunately the video server's source isn't always connected.

In my web-app I switch an IMG element's src back and forth between static JPG images and this live MJPG source which seems to exacerbate the problem.
Comment 1 David Kilzer (:ddkilzer) 2007-07-21 22:51:19 PDT
Thanks for the bug report, Chas!  Could you post a crash log as well?
Comment 2 Alexey Proskuryakov 2007-07-22 01:06:12 PDT
I'm only getting a black rectangle instead of a movie (also when loading directly). Same results in Safari 2 and in Firefox.
Comment 3 Chas Conway 2007-07-22 07:49:33 PDT
Created attachment 15621 [details]
Crashlog from Apple Safari 3 beta

Start Safari, load MJPG_demo.php page, click "Switch image to MJPG".  Even if there is not currently any video source, you should still see grey bars flickering across the bottom of the image (which is not part of the video stream;  shouldn't be there).  Now closing the window with the red button causes a crash.
Comment 4 Chas Conway 2007-07-22 07:55:22 PDT
(In reply to comment #2)
> I'm only getting a black rectangle instead of a movie (also when loading
> directly). Same results in Safari 2 and in Firefox.
> 

That's correct.  The Axis video server is attached to a microscope that's not always in use (more frequently during 9-5, central time zone).  Even when the real image is totally black, in apple's public beta of Safari 3 there should be flickering grey bars along the bottom of the image when you click "Switch to MJPG".  The distortion would be worse if there was an image showing.

When testing again I can't confirm that the newest Webkit nightly I have shows the flickering grey bars.  It doesn't seem to have the same crash as the crashlog I posted either.
Comment 5 David Kilzer (:ddkilzer) 2007-07-22 08:31:47 PDT
I don't see a crash with a local debug build of WebKit r24507 with Safari 3.0 (522.12) on Mac OS X 10.4.10 (8R218).  I also don't see any gray bars flickering on the screen after clicking the button.

Comment 6 David Kilzer (:ddkilzer) 2007-07-22 08:37:04 PDT
Using the Safari 3.0.2 (522.12) beta (no nightly WebKit), the steps to reproduce causes a crash, and I see the gray bars at the bottom of the image.

Comment 7 David Kilzer (:ddkilzer) 2007-07-22 08:38:40 PDT
Looks like this bug may be a combination of Bug 13360 and Bug 13759.  In any case, it's fixed on ToT WebKit, so marking as RESOLVED/FIXED.