Bug 14703 - No contextual menus in webviews
Summary: No contextual menus in webviews
Status: RESOLVED DUPLICATE of bug 14658
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh Intel OS X 10.4
: P1 Blocker
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-21 09:24 PDT by opendarwin
Modified: 2007-07-21 10:20 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description opendarwin 2007-07-21 09:24:10 PDT
Overview Description:
Contexual menus do not work at all in webviews. If you control-click in web page, no contextual menu appears, and there's always an error logged such as the following: *** -[NSCFArray objectAtIndex:]: index (4) beyond bounds (4)

Steps to Reproduce:
(1) Build WebKit from revision 24507.
(2) Run the run-safari script.
(3) Load a web page, such as http://www.apple.com/
(4) Control-click anywhere in the page

Expected Results:
A contextual menu appears.

Actual Results:
No contextual menu appears.  An error is logged, e.g., *** -[NSCFArray objectAtIndex:]: index (1) beyond bounds (1).

Build & Platform:
WebKit revision 24507 on Mac OS X 10.4.10 Intel, MacBook Pro.

Additional Information:
I've confirmed this bug in both Safari and Vienna (http://vienna-rss.sourceforge.net/vienna2.php), another WebKit app.

Charles Gaudette in #webkit (irc.freenode.net) states that the bug does not occur using PPC, OS X 10.4.10, Safari 3.0.2 beta, r24501.
Comment 1 Matt Lilek 2007-07-21 10:20:10 PDT

*** This bug has been marked as a duplicate of 14658 ***