Bug 14698 - Resize event fails to fire on iframes.
Summary: Resize event fails to fire on iframes.
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 523.x (Safari 3)
Hardware: All All
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-20 15:08 PDT by bontakun
Modified: 2010-03-06 17:51 PST (History)
3 users (show)

See Also:


Attachments
The zip file contains a root.html and iframe.html to demonstrate that resize events are not fired inside the iframe (1.02 KB, application/octet-stream)
2007-09-01 09:34 PDT, Dragos Georgita
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description bontakun 2007-07-20 15:08:09 PDT
The resize event fails to fire on iframes.
Comment 1 David Kilzer (:ddkilzer) 2007-07-21 08:28:27 PDT
Thanks for the bug report, Ben!  Could you provide a test case or a web page where this is an issue?

Comment 2 Dragos Georgita 2007-09-01 09:34:23 PDT
Created attachment 16174 [details]
The zip file contains a root.html and iframe.html to demonstrate that resize events are not fired inside the iframe

Just open root.html in webkit.
Resize the window -> it only displays the logger for the ROOT events, missing those of the IFRAME.
The same thing is true for FRAMEs
Comment 3 Sriram 2009-07-05 11:04:41 PDT
Works for me with r45546
Comment 4 Daniel Bates 2010-03-06 17:51:38 PST
Works for me as well using Safari Version 4.0.4 (6531.21.10). It looks like the fix for this issue was addressed in change set 28371 <http://trac.webkit.org/changeset/28371> (<rdar://problem/5346452>), which included the layout test <http://trac.webkit.org/browser/trunk/LayoutTests/fast/events/resize-subframe.html> to prevent a regression.