Bug 146702 - Add actions to image previews
Summary: Add actions to image previews
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-07 16:26 PDT by Beth Dakin
Modified: 2015-07-08 11:00 PDT (History)
6 users (show)

See Also:


Attachments
Patch (9.59 KB, patch)
2015-07-07 16:35 PDT, Beth Dakin
no flags Details | Formatted Diff | Diff
Patch (9.78 KB, patch)
2015-07-07 17:33 PDT, Beth Dakin
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Beth Dakin 2015-07-07 16:26:25 PDT
Add actions to image previews

<rdar://problem/21642654>
Comment 1 Beth Dakin 2015-07-07 16:35:37 PDT
Created attachment 256332 [details]
Patch
Comment 2 WebKit Commit Bot 2015-07-07 16:38:27 PDT
Attachment 256332 [details] did not pass style-queue:


ERROR: Source/WebKit2/UIProcess/WKImagePreviewViewController.mm:31:  Alphabetical sorting problem.  [build/include_order] [4]
ERROR: Source/WebKit2/UIProcess/ios/WKActionSheetAssistant.mm:309:  The parameter name "!" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 2 in 6 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Beth Dakin 2015-07-07 17:33:51 PDT
Created attachment 256337 [details]
Patch
Comment 4 WebKit Commit Bot 2015-07-07 17:35:56 PDT
Attachment 256337 [details] did not pass style-queue:


ERROR: Source/WebKit2/UIProcess/ios/WKActionSheetAssistant.mm:309:  The parameter name "!" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 1 in 6 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Yongjun Zhang 2015-07-08 10:43:36 PDT
Comment on attachment 256337 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=256337&action=review

> Source/WebKit2/UIProcess/WKImagePreviewViewController.h:38
> +    _WKActivatedElementInfo *_activatedElementInfo;

I think we should retain the _activeElementInfo.

> Source/WebKit2/UIProcess/ios/WKActionSheetAssistant.mm:298
> +    NSURL *targetURL = [NSURL URLWithString:positionInformation.url];

Nit: Could we use _web_URLWithWTFString: here?

The patch looks good to me, I will let a WebKit reviewer to comment.
Comment 6 Beth Dakin 2015-07-08 10:44:31 PDT
(In reply to comment #5)
> Comment on attachment 256337 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=256337&action=review
> 
> > Source/WebKit2/UIProcess/WKImagePreviewViewController.h:38
> > +    _WKActivatedElementInfo *_activatedElementInfo;
> 
> I think we should retain the _activeElementInfo.
> 

Will do.

> > Source/WebKit2/UIProcess/ios/WKActionSheetAssistant.mm:298
> > +    NSURL *targetURL = [NSURL URLWithString:positionInformation.url];
> 
> Nit: Could we use _web_URLWithWTFString: here?
> 

Yes!

> The patch looks good to me, I will let a WebKit reviewer to comment.
Comment 7 Beth Dakin 2015-07-08 11:00:38 PDT
Thanks all! http://trac.webkit.org/changeset/186515