Bug 146420 - Media Session: Removing an element from a media session should also remove it from the sets of active participating elements
Summary: Media Session: Removing an element from a media session should also remove it...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks: 145411
  Show dependency treegraph
 
Reported: 2015-06-29 13:30 PDT by Matt Rajca
Modified: 2015-06-29 16:17 PDT (History)
7 users (show)

See Also:


Attachments
Patch (1.56 KB, patch)
2015-06-29 14:06 PDT, Matt Rajca
eric.carlson: review+
buildbot: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews104 for mac-mavericks-wk2 (617.23 KB, application/zip)
2015-06-29 14:48 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Rajca 2015-06-29 13:30:33 PDT
Removing an element from a media session should also remove it from the sets of active participating elements (which are subsets of participating elements).
Comment 1 Radar WebKit Bug Importer 2015-06-29 13:31:34 PDT
<rdar://problem/21597787>
Comment 2 Matt Rajca 2015-06-29 14:06:59 PDT
Created attachment 255775 [details]
Patch
Comment 3 Eric Carlson 2015-06-29 14:09:07 PDT
Comment on attachment 255775 [details]
Patch

Is it possible to add a test for this?
Comment 4 Build Bot 2015-06-29 14:48:03 PDT
Comment on attachment 255775 [details]
Patch

Attachment 255775 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/5460256620544000

New failing tests:
svg/W3C-SVG-1.1/animate-elem-02-t.svg
Comment 5 Build Bot 2015-06-29 14:48:06 PDT
Created attachment 255778 [details]
Archive of layout-test-results from ews104 for mac-mavericks-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews104  Port: mac-mavericks-wk2  Platform: Mac OS X 10.9.5
Comment 6 Matt Rajca 2015-06-29 16:12:36 PDT
(In reply to comment #3)
> Comment on attachment 255775 [details]
> Patch
> 
> Is it possible to add a test for this?

I filed a new bug (Bug 146436) for this.
Comment 7 Matt Rajca 2015-06-29 16:15:58 PDT
Committed r186094: <http://trac.webkit.org/changeset/186094>
Comment 8 Matt Rajca 2015-06-29 16:17:59 PDT
(In reply to comment #5)
> Created attachment 255778 [details]
> Archive of layout-test-results from ews104 for mac-mavericks-wk2
> 
> The attached test failures were seen while running run-webkit-tests on the
> mac-wk2-ews.
> Bot: ews104  Port: mac-mavericks-wk2  Platform: Mac OS X 10.9.5

The build failures above are unrelated to this change as its behind a feature flag.