RESOLVED FIXED 146280
Improve JSDOMPromise callPromiseFunction naming
https://bugs.webkit.org/show_bug.cgi?id=146280
Summary Improve JSDOMPromise callPromiseFunction naming
youenn fablet
Reported 2015-06-24 08:33:57 PDT
Following on bug 146060, we could do some improvements. >> Source/WebCore/bindings/js/JSDOMPromise.h:62 >> +template<class JSClassName> > >The type here is the JavaScript class, not the JavaScript class name. I suggest the name WrapperClass here instead of JSClassName. Also, we almost always use typename rather >than class in templates, although I’m not entirely sure why. > >> Source/WebCore/bindings/js/JSDOMPromise.h:63 >> +inline JSC::JSValue callPromiseFunction(JSC::ExecState& state, JSClassName& jsObject, JSC::EncodedJSValue promiseFunction(JSC::ExecState*, JSClassName*, >JSC::JSPromiseDeferred*)) > >A typical name used in bindings for what we are calling jsObject here is “wrapper”
Attachments
Patch (2.13 KB, patch)
2015-06-24 08:37 PDT, youenn fablet
no flags
youenn fablet
Comment 1 2015-06-24 08:37:01 PDT
youenn fablet
Comment 2 2015-06-24 08:38:38 PDT
Given the modifications are already suggested as part of a review, I do not think a review is needed. But just in case, I will wait for tomorrow to cq it.
WebKit Commit Bot
Comment 3 2015-06-24 12:08:59 PDT
Comment on attachment 255483 [details] Patch Clearing flags on attachment: 255483 Committed r185919: <http://trac.webkit.org/changeset/185919>
WebKit Commit Bot
Comment 4 2015-06-24 12:09:03 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.