Implement step 5 and 6 of https://streams.spec.whatwg.org/#cancel-readable-stream
Created attachment 255346 [details] Patch
Comment on attachment 255346 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=255346&action=review > Source/WebCore/bindings/js/ReadableJSStream.cpp:164 > +static JSFunction* createCancelResultFulfilledFunction(ExecState& exec, ReadableJSStream& jsStream) I would name this argument “stream”, not “jsStream”. I don’t think the prefix does anything significant to help programmers understand the code. > Source/WebCore/bindings/js/ReadableJSStream.cpp:166 > + RefPtr<ReadableJSStream> readableStream = &jsStream; I know we need a different name for this local, but it seems that adding the word “readable” doesn’t do much good to explain why a local variable is needed. I think protectedStream would be a better name. > Source/WebCore/bindings/js/ReadableJSStream.cpp:185 > + ExecState& exec= *globalObject()->globalExec(); Missing space before "=". I suggest in new code we use “state” for our ExecState& and we can keep using “exec” for ExecState*.
Created attachment 255403 [details] Patch for landing
Comment on attachment 255403 [details] Patch for landing Clearing flags on attachment: 255403 Committed r185872: <http://trac.webkit.org/changeset/185872>
All reviewed patches have been landed. Closing bug.