Bug 146198 - Page load performance regression due to bugs.webkit.org/show_bug.cgi?id=145542
Summary: Page load performance regression due to bugs.webkit.org/show_bug.cgi?id=145542
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-21 23:15 PDT by Gavin Barraclough
Modified: 2015-06-22 05:52 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gavin Barraclough 2015-06-21 23:15:03 PDT
We've tracked down a 1%-2% regression in page load performance to:
    http://trac.webkit.org/changeset/185320
    https://bugs.webkit.org/show_bug.cgi?id=145542

From code inspection it looks like this is going to synchronously check for a proxy being enabled on every page load (assuming page loads are at least 5s apart). Checking for a proxy being enabled is likely expensive; if we really need to do so this probably has to happen on a path that doesn't block page loads.
Comment 1 Gavin Barraclough 2015-06-21 23:33:20 PDT
Rolled out r185320 in r185818.
Comment 2 Gyuyoung Kim 2015-06-22 00:18:47 PDT
EFL and GTK port builds have been broken since this revert.
Comment 3 Michael Catanzaro 2015-06-22 05:52:20 PDT
Build should be fixed; we'll use bug #145542 to try to land this again.