Bug 14614 - REGRESSION (r14597): Odd spacing at marware.com
Summary: REGRESSION (r14597): Odd spacing at marware.com
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.marware.com/PRODUCTS/iPhon...
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2007-07-13 14:10 PDT by Charlie Burtoff
Modified: 2008-07-17 01:09 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Charlie Burtoff 2007-07-13 14:10:38 PDT
Hello,

	I apologize in advance if I'm filling this bug incorrectly or to the wrong group. 

http://www.marware.com/PRODUCTS/iPhone-Cases

When I visit the URL above in FF or Safari in tiger the spacing between the products is correct, when I use webkit or my iphone (for what its worth) the spacing on the items listed on that page increase. 

Once again, I apologize if this is being filled handled incorrectly; sorry.
Comment 1 Alexey Proskuryakov 2007-07-14 02:12:25 PDT
Confirmed as a regression with r24241, thank you for reporting this!

One needs to scroll the page down to see the problem.
Comment 2 mitz 2007-07-14 03:46:42 PDT
The site sends different HTML to Safari than it sends to Firefox or curl. For example, curl sees

<tr valign='top' height=85>

where Safari gets

<tr valign='top' height=595>

Haven't checked with old Safari yet.
Comment 3 mitz 2007-07-14 04:25:53 PDT
Regressed in <http://trac.webkit.org/projects/webkit/changeset/14597>, fix for bug 3297. The website seems to employ a Safari-specific workaround for bug 3297. They should probably change the scope of the workaround.
Comment 4 Alexey Proskuryakov 2007-07-14 06:32:16 PDT
Mitz has discovered that one needs to trash marware.com cookies in addition to spoofing User Agent in order to get a Firefox version of the page, which works correctly. Moving to evangelism.
Comment 5 David Kilzer (:ddkilzer) 2007-07-14 16:15:15 PDT
I just sent an email to info@marware.com about the need to remove this workaround on their web site.

Comment 6 David Kilzer (:ddkilzer) 2007-07-14 16:16:25 PDT
(In reply to comment #5)
> I just sent an email to info@marware.com about the need to remove this
> workaround on their web site.

And a customer support case was immediately created!

Case # SUP107530 Created: Web site contains Safari-specific workaround which needs to be removed

Comment 7 Sam Stigler 2007-11-18 22:11:02 PST
The original URL given is now a 404 redirect to marware.com; the correct URL is http://www.marware.com/PRODUCTS/iPhone-Products .
Comment 8 David Kilzer (:ddkilzer) 2007-11-18 22:51:14 PST
(In reply to comment #6)
> (In reply to comment #5)
> > I just sent an email to info@marware.com about the need to remove this
> > workaround on their web site.
> 
> And a customer support case was immediately created!
> 
> Case # SUP107530 Created: Web site contains Safari-specific workaround which
> needs to be removed

I haven't heard anything since this was created, although I haven't tried to follow-up either.

Comment 9 Mark Malone 2007-11-19 10:21:28 PST
I'll ping the Apple folks with the Marware relationship.
Comment 10 Robert Blaut 2008-02-10 23:05:58 PST
It seems the bug is fixed. No more huge space between products. Any confirmations?
Comment 11 Robert Blaut 2008-07-17 01:09:44 PDT
(In reply to comment #10)
> It seems the bug is fixed. No more huge space between products. Any
> confirmations?
> 

As I said a half year ago the page renders correctly now in the latest Webkit. Closing as fixed.