Bug 146100 - Rename "Deconstruction" to "Destructuring" throughout JSC
Summary: Rename "Deconstruction" to "Destructuring" throughout JSC
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Saam Barati
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-17 23:45 PDT by Saam Barati
Modified: 2015-07-02 16:54 PDT (History)
10 users (show)

See Also:


Attachments
patch (85.15 KB, patch)
2015-07-01 10:46 PDT, Saam Barati
no flags Details | Formatted Diff | Diff
patch (92.29 KB, patch)
2015-07-01 16:19 PDT, Saam Barati
mark.lam: review+
Details | Formatted Diff | Diff
patch (92.62 KB, patch)
2015-07-02 14:05 PDT, Saam Barati
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Saam Barati 2015-06-17 23:45:44 PDT
I think it'd be nice to use the names the spec uses on this. 
Any objections?
Comment 2 Mark Lam 2015-07-01 11:18:42 PDT
Please rebase the patch.
Comment 3 Saam Barati 2015-07-01 16:19:54 PDT
Created attachment 255965 [details]
patch
Comment 4 WebKit Commit Bot 2015-07-01 16:22:21 PDT
Attachment 255965 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/parser/NodeConstructors.h:830:  l is incorrectly named. Don't use the single letter 'l' as an identifier name.  [readability/naming] [4]
Total errors found: 1 in 22 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Mark Lam 2015-07-02 13:05:50 PDT
Comment on attachment 255965 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=255965&action=review

r=me with suggested fix.

> Source/JavaScriptCore/parser/NodeConstructors.h:830
> -    inline ParameterNode::ParameterNode(ParameterNode* l, PassRefPtr<DeconstructionPatternNode> pattern)
> +    inline ParameterNode::ParameterNode(ParameterNode* l, PassRefPtr<DestructuringPatternNode> pattern)

I know this is not your doing, but since you’re touching this code, would you mind renaming “l” here to something like “lastParam” to please the style checker.  I’m guessing that’s the intended meaning of “l”?
Comment 6 Saam Barati 2015-07-02 14:05:37 PDT
Created attachment 256034 [details]
patch

With renamed parameter
Comment 7 WebKit Commit Bot 2015-07-02 16:54:10 PDT
Comment on attachment 256034 [details]
patch

Clearing flags on attachment: 256034

Committed r186246: <http://trac.webkit.org/changeset/186246>
Comment 8 WebKit Commit Bot 2015-07-02 16:54:15 PDT
All reviewed patches have been landed.  Closing bug.