Bug 145922 - [GTK] Fix deprecated-register warning in the generated WebKitMarshal.cpp
Summary: [GTK] Fix deprecated-register warning in the generated WebKitMarshal.cpp
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Csaba Osztrogonác
URL:
Keywords:
Depends on:
Blocks: 145121
  Show dependency treegraph
 
Reported: 2015-06-12 04:26 PDT by Csaba Osztrogonác
Modified: 2015-06-15 06:10 PDT (History)
6 users (show)

See Also:


Attachments
Patch (3.05 KB, patch)
2015-06-15 04:22 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2015-06-12 04:26:11 PDT
DerivedSources/webkit2gtk/webkit2/WebKitMarshal.cpp:65:3: warning: 'register' storage class specifier is deprecated [-Wdeprecated-register]
  register GMarshalFunc_BOOLEAN__BOXED callback;
  ^~~~~~~~~
DerivedSources/webkit2gtk/webkit2/WebKitMarshal.cpp:66:3: warning: 'register' storage class specifier is deprecated [-Wdeprecated-register]
  register GCClosure *cc = (GCClosure*) closure;
  ^~~~~~~~~

...

The problem is that WebKitMarshal.cpp is generated by glib-genmarshal. To fix 
it properly, we should fix it in upstream or patch the glib jhbuild module.
Or we should simply disable this warning for this file only.
Comment 1 Michael Catanzaro 2015-06-14 09:59:52 PDT
(In reply to comment #0)
> To fix it properly, we should fix it in upstream

Done. I usually build inside GNOME jhbuild, so the problem is gone for me :)

> or patch the glib jhbuild module. Or we should simply disable this warning for this file only.

^ But to fix the issue with WebKit jhbuild, we still need to do one of the above.
Comment 2 Csaba Osztrogonác 2015-06-15 04:22:02 PDT
Created attachment 254872 [details]
Patch

Thanks for the quick fix. I prefer adding your upstream patch to the WebKit's jhbuild
Comment 3 WebKit Commit Bot 2015-06-15 06:10:18 PDT
Comment on attachment 254872 [details]
Patch

Clearing flags on attachment: 254872

Committed r185550: <http://trac.webkit.org/changeset/185550>
Comment 4 WebKit Commit Bot 2015-06-15 06:10:22 PDT
All reviewed patches have been landed.  Closing bug.