Bug 145783 - Support transform-box to switch sizing box in SVG
Summary: Support transform-box to switch sizing box in SVG
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
: 171023 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-06-08 21:54 PDT by Dirk Schulze
Modified: 2017-05-22 12:39 PDT (History)
8 users (show)

See Also:


Attachments
Patch (35.91 KB, patch)
2017-05-20 15:06 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Patch (37.47 KB, patch)
2017-05-20 21:21 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Schulze 2015-06-08 21:54:28 PDT
transform-box was added to CSS Transforms to allow the user to switch between the objectBoundingBox and the SVG viewport for computing the transform origin and the reference dimension for transforms with percentage.

http://dev.w3.org/csswg/css-transforms/#transform-box
Comment 1 Fredrik Söderquist 2017-03-28 07:33:32 PDT
Gecko is set to ship this in version 55, and an implementation will land in Blink shortly. It'd be good to have some feedback from WebKit, especially wrt https://github.com/w3c/csswg-drafts/issues/857.
Comment 2 Simon Fraser (smfr) 2017-05-05 11:06:30 PDT
*** Bug 171023 has been marked as a duplicate of this bug. ***
Comment 3 Simon Fraser (smfr) 2017-05-16 23:01:41 PDT
Following https://github.com/w3c/csswg-drafts/issues/928, implementing transform-box will be a behavior change. Percentage values in transform-origin and transforms will no longer resolve against the fill-box by default, but instead use view-box.
Comment 4 Simon Fraser (smfr) 2017-05-20 15:06:58 PDT
Created attachment 310781 [details]
Patch
Comment 5 Simon Fraser (smfr) 2017-05-20 21:21:49 PDT
Created attachment 310790 [details]
Patch
Comment 6 Dean Jackson 2017-05-22 11:51:02 PDT
Comment on attachment 310790 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=310790&action=review

> Source/WebCore/css/CSSProperties.json:5963
> +            "codegen-properties": {
> +            },

Remove?

> Source/WebCore/rendering/style/RenderStyle.cpp:1134
> +    FloatPoint3D originTranslate;

originTranslation? You're nouning a verb :)
Comment 7 WebKit Commit Bot 2017-05-22 12:19:28 PDT
Comment on attachment 310790 [details]
Patch

Clearing flags on attachment: 310790

Committed r217236: <http://trac.webkit.org/changeset/217236>
Comment 8 WebKit Commit Bot 2017-05-22 12:19:30 PDT
All reviewed patches have been landed.  Closing bug.
Comment 9 Radar WebKit Bug Importer 2017-05-22 12:39:05 PDT
<rdar://problem/32332230>