WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
145677
Crash in EventDispatcher::dispatchEvent entering a location on Google Maps
https://bugs.webkit.org/show_bug.cgi?id=145677
Summary
Crash in EventDispatcher::dispatchEvent entering a location on Google Maps
Simon Fraser (smfr)
Reported
2015-06-04 17:25:11 PDT
Crash in EventDispatcher::dispatchEvent entering a location on Google Maps
Attachments
Patch
(7.19 KB, patch)
2015-06-04 17:30 PDT
,
Simon Fraser (smfr)
no flags
Details
Formatted Diff
Diff
View All
Add attachment
proposed patch, testcase, etc.
Simon Fraser (smfr)
Comment 1
2015-06-04 17:30:23 PDT
Created
attachment 254318
[details]
Patch
Simon Fraser (smfr)
Comment 2
2015-06-04 17:30:48 PDT
rdar://problem/20698280
Darin Adler
Comment 3
2015-06-04 17:37:14 PDT
Comment on
attachment 254318
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=254318&action=review
> Source/WebCore/ChangeLog:23 > + Hard to make a test because this is timing sensitive.
No way at all? Seems so likely someone will re-break this!
> Source/WebCore/dom/EventDispatcher.cpp:344 > + event->setTarget(target); > + if (!event->target()) > + return true;
Seems a little strange to set the null target on the event before returning. Is that better than returning and not setting the target at all?
> Source/WebCore/dom/EventDispatcher.cpp:433 > + m_path.append(std::make_unique<MouseOrFocusEventContext>(node, currentTarget, target));
Should we be doing this if currentTarget is null?
> Source/WebCore/dom/EventDispatcher.cpp:436 > + m_path.append(std::make_unique<TouchEventContext>(node, currentTarget, target));
Should we be doing this if currentTarget is null?
> Source/WebCore/dom/EventDispatcher.cpp:439 > + m_path.append(std::make_unique<EventContext>(node, currentTarget, target));
Should we be doing this if currentTarget is null?
> Source/WebCore/page/animation/AnimationController.cpp:112 > + m_elementChangesToDispatch.removeAllMatching([element] (const Ref<Element>& currElement) { > + return &currElement.get() == element; > + });
Could we call it otherElement rather than currElement? Nicer to use words than word fragments.
WebKit Commit Bot
Comment 4
2015-06-04 18:24:23 PDT
Comment on
attachment 254318
[details]
Patch Clearing flags on attachment: 254318 Committed
r185232
: <
http://trac.webkit.org/changeset/185232
>
WebKit Commit Bot
Comment 5
2015-06-04 18:24:28 PDT
All reviewed patches have been landed. Closing bug.
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug