Bug 145402 - Flexbox does not wrap
Summary: Flexbox does not wrap
Status: RESOLVED DUPLICATE of bug 136041
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.10
: P2 Normal
Assignee: Nobody
URL: http://jsfiddle.net/3zd7yspg/1/
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-26 22:01 PDT by Daniel Sieradski
Modified: 2016-06-02 17:15 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Sieradski 2015-05-26 22:01:25 PDT
See http://jsfiddle.net/3zd7yspg/1/

Wraps properly in Chrome and Firefox. Does not wrap in Safari or Webkit nightly build.

This property appears to be ignored:
  -webkit-flex-wrap: wrap;
Comment 1 Thomas ZILLIOX 2015-06-09 08:04:00 PDT
Here is a working demo of flex-wrapping in Safari 8.0.
http://codepen.io/tzi/full/xGdNEK/
Comment 2 Thomas ZILLIOX 2015-06-09 08:22:09 PDT
The fiddle of Daniel doesn't work because of the `min-width` set on the flex items.
So it's a duplicate ticket of #136041 https://bugs.webkit.org/show_bug.cgi?id=136041
Comment 3 Jon Lee 2016-06-02 17:15:11 PDT

*** This bug has been marked as a duplicate of bug 136041 ***