RESOLVED FIXED145116
Rename createIterResultObject as createIteratorResultObject
https://bugs.webkit.org/show_bug.cgi?id=145116
Summary Rename createIterResultObject as createIteratorResultObject
youenn fablet
Reported 2015-05-17 23:40:04 PDT
Following on bug 144790 first review, it might be good to rename createIterResultObject as createIteratorResultObject before starting using it in WebCore.
Attachments
Patch (4.52 KB, patch)
2015-05-18 01:49 PDT, youenn fablet
no flags
Patch for landing (4.54 KB, patch)
2015-05-19 12:46 PDT, youenn fablet
no flags
youenn fablet
Comment 1 2015-05-18 01:49:08 PDT
WebKit Commit Bot
Comment 2 2015-05-18 01:51:10 PDT
Attachment 253311 [details] did not pass style-queue: ERROR: Source/JavaScriptCore/runtime/IteratorOperations.h:34: The parameter name "value" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/runtime/IteratorOperations.h:40: The parameter name "value" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 2 in 5 files If any of these errors are false positives, please file a bug against check-webkit-style.
youenn fablet
Comment 3 2015-05-18 08:09:06 PDT
Comment on attachment 253311 [details] Patch Latest patch for bug 144790 makes uses of this renamed and newly exported method. See https://bugs.webkit.org/attachment.cgi?id=253325&action=review
Darin Adler
Comment 4 2015-05-19 08:55:08 PDT
Comment on attachment 253311 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=253311&action=review > Source/JavaScriptCore/runtime/IteratorOperations.h:34 > -JSValue iteratorNext(ExecState*, JSValue iterator, JSValue); > +JSValue iteratorNext(ExecState*, JSValue iterator, JSValue value); I agree with the style bot, the word "value" here is not specific enough to be helpful. I’m OK with adding an argument name here, but not sure what it would be. > Source/JavaScriptCore/runtime/IteratorOperations.h:37 > JSValue iteratorValue(ExecState*, JSValue iterResult); > bool iteratorComplete(ExecState*, JSValue iterResult); Should give iterResult a better name. > Source/JavaScriptCore/runtime/IteratorOperations.h:40 > +JS_EXPORT_PRIVATE JSObject* createIteratorResultObject(ExecState*, JSValue value, bool done); I agree with the style bot, the word "value" here is not specific enough to be helpful. I’m OK with adding an argument name here, but not sure what it would be.
youenn fablet
Comment 5 2015-05-19 12:45:15 PDT
Comment on attachment 253311 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=253311&action=review >> Source/JavaScriptCore/runtime/IteratorOperations.h:34 >> +JSValue iteratorNext(ExecState*, JSValue iterator, JSValue value); > > I agree with the style bot, the word "value" here is not specific enough to be helpful. I’m OK with adding an argument name here, but not sure what it would be. OK, let's remove it. >> Source/JavaScriptCore/runtime/IteratorOperations.h:37 >> bool iteratorComplete(ExecState*, JSValue iterResult); > > Should give iterResult a better name. OK, renaming it to iterator.
youenn fablet
Comment 6 2015-05-19 12:46:54 PDT
Created attachment 253391 [details] Patch for landing
WebKit Commit Bot
Comment 7 2015-05-19 13:08:04 PDT
Comment on attachment 253391 [details] Patch for landing Clearing flags on attachment: 253391 Committed r184586: <http://trac.webkit.org/changeset/184586>
WebKit Commit Bot
Comment 8 2015-05-19 13:08:08 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.