rdar://problem/20860410
Created attachment 253128 [details] Patch
Comment on attachment 253128 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=253128&action=review Does this patch require a change to WebKitSystemInterface? > Source/WebKit2/UIProcess/Plugins/mac/PluginInfoStoreMac.mm:114 > + return toPluginModuleLoadPolicy(WKLoadPolicyForPluginVersion(plugin.bundleIdentifier, plugin.versionString)); Source/WebKit2/UIProcess/Plugins/mac/PluginInfoStoreMac.mm:114:37: error: use of undeclared identifier 'WKLoadPolicyForPluginVersion' return toPluginModuleLoadPolicy(WKLoadPolicyForPluginVersion(plugin.bundleIdentifier, plugin.versionString));
Created attachment 256829 [details] This patch adds plumbing for supporting the ability to block plugins for non-security reasons. I'm submitting this patch on behalf of Gordon Sheridan, since responsibility for related work was transferred to me. This is intended to obsolete his previous attachment ~2 months ago since we have made a change to WKSI.
Created attachment 256830 [details] Add plumbing for the ability to block plugins for non-security reasons (Trying this again)
I think there's a WKSI change missing... but can we do this without adding new code there?
Created attachment 257017 [details] WKSI support for blocking a plug-in for non-security reasons.
Created attachment 257018 [details] WKSI support for blocking a plug-in for non-security reasons. (Take 2)
Created attachment 257019 [details] WKSI support for blocking a plug-in for non-security reasons. (Take 3)
Created attachment 257020 [details] WKSI support for blocking a plug-in for non-security reasons. (Take 4)
Created attachment 257021 [details] WKSI support for blocking a plug-in for non-security reasons. (Take 5)
Attachment 257021 [details] did not pass style-queue: ERROR: WebKitLibraries/WebKitSystemInterface.h:57: The parameter name "request" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:73: The parameter name "cgContext" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:96: The parameter name "font" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:96: The parameter name "options" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:104: The parameter name "image" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:104: The parameter name "transform" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:107: The parameter name "context" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:108: The parameter name "context" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:138: The parameter name "port" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:147: The parameter name "layer" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:147: The parameter name "context" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:160: The parameter name "request" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:165: The parameter name "response" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:183: The parameter name "type" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:184: The parameter name "sandboxExtension" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:186: The parameter name "sandboxExtension" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:187: The parameter name "sandboxExtension" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:189: The parameter name "sandboxExtension" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:194: The parameter name "path" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:194: The parameter name "rect" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:423: The parameter name "subsystem" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:441: The parameter name "eventRef" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:442: The parameter name "window" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: WebKitLibraries/WebKitSystemInterface.h:443: The parameter name "windowRef" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 24 in 2 files If any of these errors are false positives, please file a bug against check-webkit-style.
Created attachment 257117 [details] WKSI support for blocking a plug-in for non-security reasons. (Take 6)
Comment on attachment 257117 [details] WKSI support for blocking a plug-in for non-security reasons. (Take 6) Clearing flags on attachment: 257117 Committed r187038: <http://trac.webkit.org/changeset/187038>
All reviewed patches have been landed. Closing bug.
Created attachment 257130 [details] WebKit support for blocking a plugin-in for non-security reasons.
Reopened bug to take second patch.
Committed r187047: <http://trac.webkit.org/changeset/187047>