This will allow us to:
- pass around one variable instead of having two variables where one represents identifiers, and one represents captured identifiers.
This adds to the overall cleanliness of the code and abstracts this stuff away.
- Associate identifiers with flags. Specifically, indicating if a variable is a constant or not.
Now being rolled into:
*** This bug has been marked as a duplicate of bug 142944 ***