Bug 144619 - Rename ProcessThrottlerClient::{send, cancel}ProcessWillSuspend() to {send, cancel}PrepareToSuspend()
Summary: Rename ProcessThrottlerClient::{send, cancel}ProcessWillSuspend() to {send, c...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Daniel Bates
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2015-05-04 20:00 PDT by Daniel Bates
Modified: 2015-05-13 20:08 PDT (History)
7 users (show)

See Also:


Attachments
[Patch] Rename ProcessThrottlerClient functions (12.26 KB, patch)
2015-05-04 20:02 PDT, Daniel Bates
no flags Details | Formatted Diff | Diff
[Patch] Rename ProcessThrottlerClient functions (13.62 KB, patch)
2015-05-04 20:16 PDT, Daniel Bates
no flags Details | Formatted Diff | Diff
Patch (13.52 KB, patch)
2015-05-12 15:04 PDT, Daniel Bates
no flags Details | Formatted Diff | Diff
Patch (13.58 KB, patch)
2015-05-12 15:11 PDT, Daniel Bates
aestes: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Bates 2015-05-04 20:00:05 PDT
The names of the functions ProcessThrottlerClient::{send, cancel}ProcessWillSuspend() are misnomers. These functions are called when
the ProcessThrottler wants to prepare the process that it manages for suspension and changes it mind, respectively. That is, these
functions do not actually correspond to the OS decision to suspend a process or cancel the suspension of a process. We should rename
these functions to better describe their purpose.
Comment 1 Daniel Bates 2015-05-04 20:02:34 PDT
Created attachment 252366 [details]
[Patch] Rename ProcessThrottlerClient functions

I am open to name suggestions.
Comment 2 Radar WebKit Bug Importer 2015-05-04 20:04:34 PDT
<rdar://problem/20812779>
Comment 3 Daniel Bates 2015-05-04 20:16:47 PDT
Created attachment 252367 [details]
[Patch] Rename ProcessThrottlerClient functions
Comment 4 Andy Estes 2015-05-06 14:55:30 PDT
Comment on attachment 252367 [details]
[Patch] Rename ProcessThrottlerClient functions

"process" seems redundant, since in each case that term is already in the class name. What about prepareToSuspend() and cancelPrepareToSuspend()?
Comment 5 Daniel Bates 2015-05-12 15:04:19 PDT
Created attachment 252989 [details]
Patch

Renamed ProcessThrottlerClient::{send, cancel}ProcessWillSuspend() to {send, cancel}PrepareToSuspend().
Comment 6 Daniel Bates 2015-05-12 15:11:19 PDT
Created attachment 252990 [details]
Patch
Comment 7 Andy Estes 2015-05-13 16:34:31 PDT
Comment on attachment 252990 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=252990&action=review

> Source/WebKit2/ChangeLog:10
> +        and changes it mind, respectively. That is, these functions do not actually correspond to the OS decision to

changes its mind

> Source/WebKit2/ChangeLog:11
> +        suspend a process or cancel the suspension of a process. We should rename these functions an associated

and associated
Comment 8 Daniel Bates 2015-05-13 20:08:56 PDT
Committed r184326: <http://trac.webkit.org/changeset/184326>