You need to
before you can comment on or make changes to this bug.
GraphicsContextCairo.cpp could do with a cleanup.
Created an attachment (id=15292) [details]
GraphicsContextCairo code style cleanup
Created an attachment (id=15384) [details]
Cairo backend code style cleanup
This patch extends the previous one to cover more of the Cairo backend.
The question on IRC was why do we want to name it 'cr'? What does cr mean?
The answers were:
-We don't know what cr means but you can go from 'cairo_t' with finite steps to cr by removoing charachters.
-Using 'context' for GraphicsContext and another name for the cairo_t handle seems natural
-'cr' follows the habbit of cairo and Gtk+ and should be understandable by everyone having looked at cairo/Gdk/Gtk+.
Please apply this bugfix and cleanup (adding save/restore).
(From update of attachment 15384 [details])
Looks reasonable enough. I'm not particularly fond of the name "cr" but it does bring some consistency to the naming.
Landed in r24016.