Bug 144250 - [GTK][jhbuild] Mesa build failure with llvm 3.6
Summary: [GTK][jhbuild] Mesa build failure with llvm 3.6
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Joanmarie Diggs (irc: joanie)
URL:
Keywords:
Depends on: 144334
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-26 21:36 PDT by ChangSeok Oh
Modified: 2015-04-28 11:58 PDT (History)
8 users (show)

See Also:


Attachments
Patch (1.76 KB, patch)
2015-04-27 12:13 PDT, Joanmarie Diggs (irc: joanie)
no flags Details | Formatted Diff | Diff
Patch for landing (1.68 KB, patch)
2015-04-28 11:10 PDT, Zan Dobersek
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ChangSeok Oh 2015-04-26 21:36:32 PDT
Mesa build through jhbuild is failed on ubuntu 15.04.
It is caused by llvm 3.6 installed on the latest system. I found a relevant fix[1] from mesa community though. that's not possible to directly apply it to MesaLib-10.2.1.tar.bz2  since there are some gaps between 10.2.1 and upstream. We need to bump up the mesa to the version including that fix, or else we need to write an own patch based on it.
Thoughts?  

[1] http://cgit.freedesktop.org/mesa/mesa/commit/?id=065256dfc4464cb510f84d638da1b345ff65b693
Comment 1 Joanmarie Diggs (irc: joanie) 2015-04-27 12:12:13 PDT
Even if we don't change versions, the current URL is no longer valid. 10.2.1 is now an "older version". Chatting with a couple of folks, I got the impression that -- taking into account the issue reported here -- we "might as well" bump the dependency.
Comment 2 Joanmarie Diggs (irc: joanie) 2015-04-27 12:13:32 PDT
Created attachment 251765 [details]
Patch
Comment 3 ChangSeok Oh 2015-04-27 21:59:30 PDT
(In reply to comment #1)
> Even if we don't change versions, the current URL is no longer valid. 10.2.1
> is now an "older version".
yeah. That's why I'd like to hear others before doing actual something..

> Chatting with a couple of folks, I got the
> impression that -- taking into account the issue reported here -- we "might
> as well" bump the dependency.

I also lean to bump version up if no backward compatibility.
Comment 4 Marcos Chavarría Teijeiro (irc: chavaone) 2015-04-28 01:38:48 PDT
*** Bug 144318 has been marked as a duplicate of this bug. ***
Comment 5 Zan Dobersek 2015-04-28 08:00:30 PDT
Comment on attachment 251765 [details]
Patch

Let's try bumping first, and fall back to using the alternative 10.2.1 download location if there are regressions.
Comment 6 WebKit Commit Bot 2015-04-28 08:48:48 PDT
Comment on attachment 251765 [details]
Patch

Clearing flags on attachment: 251765

Committed r183477: <http://trac.webkit.org/changeset/183477>
Comment 7 WebKit Commit Bot 2015-04-28 08:48:51 PDT
All reviewed patches have been landed.  Closing bug.
Comment 8 WebKit Commit Bot 2015-04-28 09:31:05 PDT
Re-opened since this is blocked by bug 144334
Comment 9 Zan Dobersek 2015-04-28 09:44:23 PDT
The testing bots are currently in a bit of a pickle, so we wouldn't be able to properly determine whether the bumping of Mesa to 10.5.4 would cause any regressions. I reverted this for the time being, and will land the 10.2.1 relocation patch instead. After the current issues clear up, we'll come back to this and land the bump proper.
Comment 10 Zan Dobersek 2015-04-28 11:10:25 PDT
Created attachment 251866 [details]
Patch for landing

Joanie's patch, updated to properly apply on top of current trunk.
Comment 11 WebKit Commit Bot 2015-04-28 11:58:05 PDT
Comment on attachment 251866 [details]
Patch for landing

Clearing flags on attachment: 251866

Committed r183496: <http://trac.webkit.org/changeset/183496>
Comment 12 WebKit Commit Bot 2015-04-28 11:58:10 PDT
All reviewed patches have been landed.  Closing bug.