Bug 143757 - [W32] No GCC assembler code for JIT on Windows in JavaScriptCore/jit/JITStubsX86.h
Summary: [W32] No GCC assembler code for JIT on Windows in JavaScriptCore/jit/JITStubs...
Status: RESOLVED DUPLICATE of bug 132856
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 133028
  Show dependency treegraph
 
Reported: 2015-04-15 06:18 PDT by LRN
Modified: 2015-04-15 10:11 PDT (History)
2 users (show)

See Also:


Attachments
Add missing gcc asm code for JIT (11.13 KB, patch)
2015-04-15 09:48 PDT, LRN
msaboff: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description LRN 2015-04-15 06:18:45 PDT
Webkit has code for MSVC on Windows and for GCC on Linux, but not for GCC on Windows (MinGW).
Comment 1 LRN 2015-04-15 09:48:57 PDT
Created attachment 250802 [details]
Add missing gcc asm code for JIT

attachment 233444 [details] from bug 132856

Fixes linking errors like these:
  CXXLD    libjavascriptcoregtk-3.0.la
Source\\JavaScriptCore\\interpreter\\.libs\\libjavascriptcoregtk_3_0_la-Interpreter.o: In function `executeCall':
/webkitgtk-2.4.8-1/bld/../webkitgtk-2.4.8/Source/JavaScriptCore/interpreter/Interpreter.cpp:972: undefined reference to `_callToNativeFunction'
Source\\JavaScriptCore\\interpreter\\.libs\\libjavascriptcoregtk_3_0_la-Interpreter.o: In function `executeConstruct':
/webkitgtk-2.4.8-1/bld/../webkitgtk-2.4.8/Source/JavaScriptCore/interpreter/Interpreter.cpp:1040: undefined reference to `_callToNativeFunction'
Source\\JavaScriptCore\\jit\\.libs\\libjavascriptcoregtk_3_0_la-JITCode.o: In function `execute':
/webkitgtk-2.4.8-1/bld/../webkitgtk-2.4.8/Source/JavaScriptCore/jit/JITCode.cpp:48: undefined reference to `_callToJavaScript'
Source\\JavaScriptCore\\jit\\.libs\\libjavascriptcoregtk_3_0_la-JITExceptions.o: In function `genericUnwind':
/webkitgtk-2.4.8-1/bld/../webkitgtk-2.4.8/Source/JavaScriptCore/jit/JITExceptions.cpp:62: undefined reference to `_returnFromJavaScript'
Comment 2 Carlos Garcia Campos 2015-04-15 09:51:13 PDT

*** This bug has been marked as a duplicate of bug 132856 ***
Comment 3 Michael Saboff 2015-04-15 10:11:46 PDT
Comment on attachment 250802 [details]
Add missing gcc asm code for JIT

You need to rebaseline your source tree as it appears that you have an old version.  These functions have changed names and their implementation.
    callToJavaScript is now vmEntryToJavaScript
    callToNativeFunction is now vmEntryToNative
If you're using gcc, you should be using the LLInt generated versions of these assembly functions.  Make any modifications there.
You may need to make changes to the Offline assembler