Bug 143729 - Web Inspector: Expose private APIs to interact with RemoteInspector instead of going through WebKit
Summary: Web Inspector: Expose private APIs to interact with RemoteInspector instead o...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Joseph Pecoraro
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2015-04-14 15:06 PDT by Joseph Pecoraro
Modified: 2015-04-14 16:27 PDT (History)
10 users (show)

See Also:


Attachments
[PATCH] Proposed Fix (10.19 KB, patch)
2015-04-14 15:09 PDT, Joseph Pecoraro
no flags Details | Formatted Diff | Diff
[PATCH] Proposed Fix (10.21 KB, patch)
2015-04-14 15:17 PDT, Joseph Pecoraro
timothy: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Pecoraro 2015-04-14 15:06:32 PDT
* SUMMARY
Expose private APIs to interact with RemoteInspector instead of going through WebKit.

Back when remote inspection was WebView specific all of the APIs to toggle different behavior were in WebKitLegacy.framework on @class WebView. Since moving the core RemoteInspector singleton to JavaScriptCore, we've gotten away with automatically triggering things in JSContext/WebView/WKWebView but we really should provide some basic set of APIs directly. Things like (1) disable auto starting, (2) explicitly starting, (3) setting parent process information.
Comment 1 Joseph Pecoraro 2015-04-14 15:06:57 PDT
<rdar://problem/19044894>
Comment 2 Joseph Pecoraro 2015-04-14 15:09:46 PDT
Created attachment 250742 [details]
[PATCH] Proposed Fix
Comment 3 WebKit Commit Bot 2015-04-14 15:12:24 PDT
Attachment 250742 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/API/JSRemoteInspectorPrivate.h:26:  #ifndef header guard has wrong style, please use: JSRemoteInspectorPrivate_h  [build/header_guard] [5]
ERROR: Source/JavaScriptCore/API/JSRemoteInspectorPrivate.h:37:  The parameter name "pid" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSRemoteInspector.cpp:30:  Found header this file implements after other header. Should be: config.h, primary header, blank line, and then alphabetically sorted.  [build/include_order] [4]
Total errors found: 3 in 4 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Joseph Pecoraro 2015-04-14 15:17:55 PDT
Created attachment 250745 [details]
[PATCH] Proposed Fix
Comment 5 WebKit Commit Bot 2015-04-14 15:19:30 PDT
Attachment 250745 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/API/JSRemoteInspector.cpp:30:  Found header this file implements after other header. Should be: config.h, primary header, blank line, and then alphabetically sorted.  [build/include_order] [4]
Total errors found: 1 in 4 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 6 Joseph Pecoraro 2015-04-14 16:27:43 PDT
http://trac.webkit.org/changeset/182816