Bug 143654 - 'const' declarations in JSC should follow the ES6 spec
Summary: 'const' declarations in JSC should follow the ES6 spec
Status: RESOLVED DUPLICATE of bug 31813
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Saam Barati
URL:
Keywords:
Depends on: 142944
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-12 18:43 PDT by Saam Barati
Modified: 2015-07-09 18:00 PDT (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Saam Barati 2015-04-12 18:43:05 PDT
We should make 'const' use lexical scoping (https://bugs.webkit.org/show_bug.cgi?id=31813) 
and we should throw a syntax error if a const declaration does not have an initializer.
Comment 1 Saam Barati 2015-07-09 18:00:36 PDT

*** This bug has been marked as a duplicate of bug 31813 ***