Bug 14341 - rules="none" ignored in certain cases
: rules="none" ignored in certain cases
Status: VERIFIED FIXED
: WebKit
Tables
: 523.x (Safari 3)
: PC Windows XP
: P2 Normal
Assigned To:
: http://www.gtalbot.org/BrowserBugsSec...
:
:
:
  Show dependency treegraph
 
Reported: 2007-06-23 13:28 PST by
Modified: 2008-03-21 09:15 PST (History)


Attachments
Respect rules="none" (120.10 KB, patch)
2007-06-23 14:53 PST, mitz@webkit.org
mjs: review+
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-06-23 13:28:39 PST
Steps to reproduce: Load provided URL

Actual results in Safari 3.0.2 build 522.13.1: 
all 4 tables have, display a border between the 1st cell and the 2nd cell

Expected results:
all 4 tables should have, should display no border between the 1st cell and the 2nd cell

I searched for a duplicate and did not find one.

MSIE 7 and Firefox 2.0.0.4 get expected results.
------- Comment #1 From 2007-06-23 14:53:59 PST -------
Created an attachment (id=15202) [details]
Respect rules="none"

tables/mozilla_expected_failures/core/table_rules.html remains failing due to incorrect handling of colgroups with <col> children (different from bug 13793).
------- Comment #2 From 2007-06-24 18:31:04 PST -------
(From update of attachment 15202 [details])
r=me
------- Comment #3 From 2007-06-25 03:24:17 PST -------
Landed in r23759.
------- Comment #4 From 2007-06-26 01:28:17 PST -------
(In reply to comment #1)
> Created an attachment (id=15202) [edit] [details]
> tables/mozilla_expected_failures/core/table_rules.html remains failing due to
> incorrect handling of colgroups with <col> children (different from bug 13793).

Bug 14406.
------- Comment #5 From 2007-08-03 23:07:19 PST -------
Hello Mark, (Mitz?) and Maciej,

I tried the testcase with Safari 3.0.3 build 522.15.5 and I still get the actual results, not the expected results. Was the bug fixed? Just asking..
------- Comment #6 From 2007-08-04 01:00:57 PST -------
(In reply to comment #5)
> Hello Mark, (Mitz?) and Maciej,
> 
> I tried the testcase with Safari 3.0.3 build 522.15.5 and I still get the
> actual results, not the expected results. Was the bug fixed? Just asking..

The bug is fixed in the latest nightly builds, but not in Safari 3 betas. You can download a nightly build from <http://nightly.webkit.org> and verify.
------- Comment #7 From 2008-03-21 09:15:45 PST -------
Fixed in Safari 3.1 build 525.13.0

Marking as VERIFIED