Drop HTTP method from NetworkCache::Key as we only cache GET responses for now. Even when we start caching HEAD responses, we likely will not want the method to be part of the key because: - A HEAD response can be used to update the headers of a previously cached response to GET - A cached GET response may be used to satisfy subsequent HEAD requests
Created attachment 250013 [details] Patch
Comment on attachment 250013 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=250013&action=review > Source/WebKit2/NetworkProcess/cache/NetworkCacheStorage.h:80 > - static const unsigned version = 2; > + static const unsigned version = 3; You shouldn't do this. The old entries will get cleaned during normal cache shrinks (and in an unlikely event of hash collision will fail to validate). Version updates are meant to be used when the directory structure changes and be paired with code that deletes the old directory structure.
It could be renamed to diskLayoutVersion or something similarly informative.
Committed r182296: <http://trac.webkit.org/changeset/182296>
Re-opened since this is blocked by bug 143448
Created attachment 257979 [details] Patch
We can land again now that efficacy logging has been disabled.
Comment on attachment 257979 [details] Patch Clearing flags on attachment: 257979 Committed r187698: <http://trac.webkit.org/changeset/187698>
All reviewed patches have been landed. Closing bug.