Bug 143168 - load8Signed() and load16Signed() should be renamed to avoid confusion
Summary: load8Signed() and load16Signed() should be renamed to avoid confusion
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 312.x
Hardware: All All
: P2 Normal
Assignee: Michael Saboff
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-27 17:53 PDT by Michael Saboff
Modified: 2015-03-27 19:55 PDT (History)
0 users

See Also:


Attachments
Patch for lnding, already reviewed. (13.64 KB, patch)
2015-03-27 17:57 PDT, Michael Saboff
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Saboff 2015-03-27 17:53:15 PDT
It isn't clear from the names of the JSC MacroAssembler function load8Signed() and load16Signed() as to how many bits to sign extend.  The code expects sign extending to 32 bits, but the ARM64 version was sign extending to 64 bits (https://bugs.webkit.org/show_bug.cgi?id=138390).  The names of these function should reflect the number of bits they sign extend out to.
Comment 1 Michael Saboff 2015-03-27 17:57:40 PDT
Created attachment 249627 [details]
Patch for lnding, already reviewed.
Comment 2 Michael Saboff 2015-03-27 19:55:54 PDT
Committed r182098: <http://trac.webkit.org/changeset/182098>