Bug 143137 - [WK2][NetworkCache] Rename requestNeedsRevalidation() to requestRequiresRevalidation()
Summary: [WK2][NetworkCache] Rename requestNeedsRevalidation() to requestRequiresReval...
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Chris Dumez
Depends on:
Reported: 2015-03-27 10:54 PDT by Chris Dumez
Modified: 2015-03-27 13:17 PDT (History)
2 users (show)

See Also:

Patch (2.28 KB, patch)
2015-03-27 10:56 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2015-03-27 10:54:57 PDT
Rename requestNeedsRevalidation() to requestRequiresRevalidation() as I think it is more accurate. It is not the request that needs revalidating. The requests just requires us to revalidate the response.
Comment 1 Chris Dumez 2015-03-27 10:56:16 PDT
Created attachment 249584 [details]
Comment 2 Chris Dumez 2015-03-27 10:57:03 PDT
Alternatively, requestRequiresResponseRevalidation() would be clear I think but it is a bit long.
Comment 3 WebKit Commit Bot 2015-03-27 13:17:45 PDT
Comment on attachment 249584 [details]

Clearing flags on attachment: 249584

Committed r182074: <http://trac.webkit.org/changeset/182074>
Comment 4 WebKit Commit Bot 2015-03-27 13:17:49 PDT
All reviewed patches have been landed.  Closing bug.