Bug 142465 - [SVG -> OTF Converter] x-height cannot be specified
Summary: [SVG -> OTF Converter] x-height cannot be specified
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Myles C. Maxfield
URL:
Keywords:
: 140537 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-03-08 15:25 PDT by Myles C. Maxfield
Modified: 2015-03-09 12:39 PDT (History)
5 users (show)

See Also:


Attachments
Patch (3.71 KB, patch)
2015-03-08 15:26 PDT, Myles C. Maxfield
simon.fraser: review+
commit-queue: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Myles C. Maxfield 2015-03-08 15:25:07 PDT
[SVG -> OTF Converter] x-height cannot be specified
Comment 1 Myles C. Maxfield 2015-03-08 15:26:15 PDT
Created attachment 248209 [details]
Patch
Comment 2 Simon Fraser (smfr) 2015-03-08 15:54:44 PDT
Comment on attachment 248209 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=248209&action=review

> LayoutTests/ChangeLog:9
> +        For all non-system fonts, OS X disregards the font's reported x-height. Therefore,
> +        it is impossible to satisfy this test.

But is this test not useful for other platforms?
Comment 3 Myles C. Maxfield 2015-03-09 08:50:17 PDT
(In reply to comment #2)
> Comment on attachment 248209 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=248209&action=review
> 
> > LayoutTests/ChangeLog:9
> > +        For all non-system fonts, OS X disregards the font's reported x-height. Therefore,
> > +        it is impossible to satisfy this test.
> 
> But is this test not useful for other platforms?

I don't think so. The fact that the computed x-height has a particular value if it is unspecified 1. isn't in the spec, and 2. doesn't seem to be valuable. There doesn't seem to be any reason why we should hold ourselves to this particular quality of font-face.
Comment 4 Myles C. Maxfield 2015-03-09 08:54:20 PDT
*** Bug 140537 has been marked as a duplicate of this bug. ***
Comment 5 WebKit Commit Bot 2015-03-09 12:24:53 PDT
Comment on attachment 248209 [details]
Patch

Rejecting attachment 248209 [details] from commit-queue.

Failed to run "['/Volumes/Data/EWS/WebKit/Tools/Scripts/webkit-patch', '--status-host=webkit-queues.appspot.com', '--bot-id=webkit-cq-01', 'apply-attachment', '--no-update', '--non-interactive', 248209, '--port=mac']" exit_code: 2 cwd: /Volumes/Data/EWS/WebKit

Last 500 characters of output:
fast/css/ex-unit-with-no-x-height-expected.txt'
patching file LayoutTests/fast/css/ex-unit-with-no-x-height.html
rm 'LayoutTests/fast/css/ex-unit-with-no-x-height.html'
patching file LayoutTests/platform/mac/TestExpectations
Hunk #1 FAILED at 1245.
1 out of 1 hunk FAILED -- saving rejects to file LayoutTests/platform/mac/TestExpectations.rej

Failed to run "[u'/Volumes/Data/EWS/WebKit/Tools/Scripts/svn-apply', '--force', '--reviewer', u'Simon Fraser']" exit_code: 1 cwd: /Volumes/Data/EWS/WebKit

Full output: http://webkit-queues.appspot.com/results/5564885299625984
Comment 6 Myles C. Maxfield 2015-03-09 12:39:38 PDT
Committed r181277: <http://trac.webkit.org/changeset/181277>