Bug 142329 - [CSS Grid Layout] Using automatic (instead of min-content) minimums for 'auto' tracks
Summary: [CSS Grid Layout] Using automatic (instead of min-content) minimums for 'aut...
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Sergio Villar Senin
Keywords: BlinkMergeCandidate
Depends on: 146018
Blocks: 60731
  Show dependency treegraph
Reported: 2015-03-05 01:40 PST by Sergio Villar Senin
Modified: 2015-09-17 05:13 PDT (History)
6 users (show)

See Also:

Patch (81.76 KB, patch)
2015-09-15 02:05 PDT, Sergio Villar Senin
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sergio Villar Senin 2015-03-05 01:40:58 PST
This has recently changed in the specs. See https://lists.w3.org/Archives/Public/www-style/2015Jan/0166.html for more details.

The most important part is the following:

    More precisely (syntax-wise), this would allow 'auto' to be used within the
    minmax() function (it's currently forbidden) and have the 'auto' keyword map
    to minmax(auto, auto) instead of minmax(min-content, max-content).
        * As a minimum, 'auto' would mean "use the specified minimum size, or if
          that is auto, treat as 0 or min-content per Flexbox rules".
        * As a maximum, 'auto' would mean "use the max-content size".
Comment 1 Sergio Villar Senin 2015-09-14 06:01:31 PDT
This involves merging the following two patches from Blink:

* [CSSGridLayout] Use automatic minimums for 'auto' tracks r198697
* [CSS Grid Layout] The 'auto' value is valid for maxTrackBreadth property r200478
Comment 2 Sergio Villar Senin 2015-09-15 02:05:17 PDT
Created attachment 261181 [details]
Comment 3 Darin Adler 2015-09-16 10:18:04 PDT
Comment on attachment 261181 [details]

View in context: https://bugs.webkit.org/attachment.cgi?id=261181&action=review

> Source/WebCore/rendering/RenderGrid.cpp:559
> +        return LayoutUnit();

In new code we often use { } instead of LayoutUnit(); a bit more terse, not 100% sure it’s better.
Comment 4 Sergio Villar Senin 2015-09-17 05:13:53 PDT
Committed r189911: <http://trac.webkit.org/changeset/189911>