Bug 142265 - [CSS Grid Layout] ASSERTION FAILED !track.growthLimitIsInfinite() in RenderGrid::computeUsedBreadthOfGridTracks
Summary: [CSS Grid Layout] ASSERTION FAILED !track.growthLimitIsInfinite() in RenderGr...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Sergio Villar Senin
URL:
Keywords:
Depends on:
Blocks: 60731 116980
  Show dependency treegraph
 
Reported: 2015-03-04 00:59 PST by Sergio Villar Senin
Modified: 2015-03-06 00:56 PST (History)
12 users (show)

See Also:


Attachments
Patch (4.53 KB, patch)
2015-03-04 06:50 PST, Sergio Villar Senin
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews101 for mac-mavericks (550.20 KB, application/zip)
2015-03-04 07:35 PST, Build Bot
no flags Details
Archive of layout-test-results from ews107 for mac-mavericks-wk2 (691.27 KB, application/zip)
2015-03-04 07:43 PST, Build Bot
no flags Details
Removed an invalid carry return added by mistake in the expectations file (4.52 KB, patch)
2015-03-04 07:45 PST, Sergio Villar Senin
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sergio Villar Senin 2015-03-04 00:59:21 PST
Originally reported for blink https://code.google.com/p/chromium/issues/detail?id=463079 it's also failing in WebKit with the following test case.

<!DOCTYPE html>
<style>
* {
    display: -webkit-inline-grid;
    height: calc(100% - 10px);
    grid-template-rows: minmax(100%, -webkit-max-content);
}
</style>
<summary>
    <style></style>
</summary>

The problem is that when computing the height of the grid container we can get -1 and we aren't handling that case properly.
Comment 1 Sergio Villar Senin 2015-03-04 06:50:42 PST
Created attachment 247856 [details]
Patch
Comment 2 Build Bot 2015-03-04 07:35:56 PST
Comment on attachment 247856 [details]
Patch

Attachment 247856 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.appspot.com/results/6398349741654016

New failing tests:
fast/css-grid-layout/grid-indefinite-calculated-height-crash.html
Comment 3 Build Bot 2015-03-04 07:35:59 PST
Created attachment 247857 [details]
Archive of layout-test-results from ews101 for mac-mavericks

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews101  Port: mac-mavericks  Platform: Mac OS X 10.9.5
Comment 4 Build Bot 2015-03-04 07:43:37 PST
Comment on attachment 247856 [details]
Patch

Attachment 247856 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/6572637098606592

New failing tests:
fast/css-grid-layout/grid-indefinite-calculated-height-crash.html
Comment 5 Build Bot 2015-03-04 07:43:39 PST
Created attachment 247858 [details]
Archive of layout-test-results from ews107 for mac-mavericks-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews107  Port: mac-mavericks-wk2  Platform: Mac OS X 10.9.5
Comment 6 Sergio Villar Senin 2015-03-04 07:45:27 PST
Created attachment 247859 [details]
Removed an invalid carry return added by mistake in the expectations file
Comment 7 Sergio Villar Senin 2015-03-06 00:56:23 PST
Comment on attachment 247859 [details]
Removed an invalid carry return added by mistake in the expectations file

Clearing flags on attachment: 247859

Committed r181141: <http://trac.webkit.org/changeset/181141>
Comment 8 Sergio Villar Senin 2015-03-06 00:56:34 PST
All reviewed patches have been landed.  Closing bug.