Bug 142235 - bmalloc: Added missing features to the malloc zone introspection API
Summary: bmalloc: Added missing features to the malloc zone introspection API
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Geoffrey Garen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-03 14:34 PST by Geoffrey Garen
Modified: 2015-03-03 14:46 PST (History)
1 user (show)

See Also:


Attachments
Patch (4.90 KB, patch)
2015-03-03 14:36 PST, Geoffrey Garen
kling: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Geoffrey Garen 2015-03-03 14:34:41 PST
bmalloc: Added missing features to the malloc zone introspection API
Comment 1 Geoffrey Garen 2015-03-03 14:36:24 PST
Created attachment 247795 [details]
Patch
Comment 2 WebKit Commit Bot 2015-03-03 14:39:27 PST
Attachment 247795 [details] did not pass style-queue:


ERROR: Source/bmalloc/bmalloc/Zone.cpp:42:  good_size is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/bmalloc/bmalloc/Zone.cpp:60:  force_lock is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/bmalloc/bmalloc/Zone.cpp:64:  force_unlock is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/bmalloc/bmalloc/Zone.cpp:80:  type_mask is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/bmalloc/bmalloc/Zone.cpp:80:  zone_address is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Total errors found: 5 in 2 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Geoffrey Garen 2015-03-03 14:41:37 PST
> ERROR: Source/bmalloc/bmalloc/Zone.cpp:42:  good_size is incorrectly named.
> Don't use underscores in your identifier names. 
> [readability/naming/underscores] [4]
> ERROR: Source/bmalloc/bmalloc/Zone.cpp:60:  force_lock is incorrectly named.
> Don't use underscores in your identifier names. 
> [readability/naming/underscores] [4]
> ERROR: Source/bmalloc/bmalloc/Zone.cpp:64:  force_unlock is incorrectly
> named. Don't use underscores in your identifier names. 
> [readability/naming/underscores] [4]
> ERROR: Source/bmalloc/bmalloc/Zone.cpp:80:  type_mask is incorrectly named.
> Don't use underscores in your identifier names. 
> [readability/naming/underscores] [4]
> ERROR: Source/bmalloc/bmalloc/Zone.cpp:80:  zone_address is incorrectly
> named. Don't use underscores in your identifier names. 
> [readability/naming/underscores] [4]

These are to match the callback API.
Comment 4 Andreas Kling 2015-03-03 14:42:42 PST
Comment on attachment 247795 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=247795&action=review

r=me

> Source/bmalloc/ChangeLog:26
> +        Zone class since the can stand alone.

the can stand alone.

> Source/bmalloc/bmalloc/Zone.cpp:71
> +static void statistics(malloc_zone_t*, malloc_statistics_t* statistics)
> +{
> +    memset(statistics, 0, sizeof(malloc_statistics_t));
> +}

I guess we can assume that no one would be annoying enough to call this with statistics=nullptr.
Comment 5 Geoffrey Garen 2015-03-03 14:46:20 PST
Committed r180958: <http://trac.webkit.org/changeset/180958>