Bug 142221 - Test legacy event handler attributes (ones with names like "onclick")
Summary: Test legacy event handler attributes (ones with names like "onclick")
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Darin Adler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-03 09:36 PST by Darin Adler
Modified: 2019-02-06 09:03 PST (History)
4 users (show)

See Also:


Attachments
Patch (85.65 KB, patch)
2015-03-03 09:36 PST, Darin Adler
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2015-03-03 09:36:31 PST
Test legacy event handler attributes (ones with names like "onclick")
Comment 1 Darin Adler 2015-03-03 09:36:57 PST
Created attachment 247765 [details]
Patch
Comment 2 Darin Adler 2015-03-03 09:37:54 PST
Going to use this test to make sure I don’t break anything while refactoring the handling for these attributes.
Comment 3 WebKit Commit Bot 2015-03-03 13:20:37 PST
Comment on attachment 247765 [details]
Patch

Clearing flags on attachment: 247765

Committed r180952: <http://trac.webkit.org/changeset/180952>
Comment 4 WebKit Commit Bot 2015-03-03 13:20:42 PST
All reviewed patches have been landed.  Closing bug.
Comment 5 Brent Fulgham 2015-03-03 17:30:53 PST
This causes a test failure on Windows. Should I rebaseline the Windows tests to match this test's output?

Based on the test output difference, this might just be some kind of mistake in the Windows reporting logic:

--- /home/buildbot/slave/win-release-tests/build/layout-test-results/fast/dom/legacy-event-handler-attributes-expected.txt
+++ /home/buildbot/slave/win-release-tests/build/layout-test-results/fast/dom/legacy-event-handler-attributes-actual.txt
@@ -479,9 +479,9 @@
 FAIL testElementAttribute(audioElement, "webkitanimationend") should be target. Was script: none; content: target.
 FAIL testElementAttribute(audioElement, "webkitanimationiteration") should be target. Was script: none; content: target.
 FAIL testElementAttribute(audioElement, "webkitanimationstart") should be target. Was script: none; content: target.
-FAIL testElementAttribute(audioElement, "webkitkeyadded") should be target. Was script: target; content: none.
-FAIL testElementAttribute(audioElement, "webkitkeyerror") should be target. Was script: target; content: none.
-FAIL testElementAttribute(audioElement, "webkitkeymessage") should be target. Was script: target; content: none.
+FAIL testElementAttribute(audioElement, "webkitkeyadded") should be target. Was none.
+FAIL testElementAttribute(audioElement, "webkitkeyerror") should be target. Was none.
+FAIL testElementAttribute(audioElement, "webkitkeymessage") should be target. Was none.
 FAIL testElementAttribute(audioElement, "webkitpresentationmodechanged") should be target. Was none.
 FAIL testElementAttribute(audioElement, "webkittransitionend") should be target. Was script: none; content: target.
 PASS testElementAttribute(audioElement, "wheel") is "target"
@@ -579,9 +579,9 @@
 FAIL testElementAttribute(videoElement, "webkitanimationend") should be target. Was script: none; content: target.
 FAIL testElementAttribute(videoElement, "webkitanimationiteration") should be target. Was script: none; content: target.
 FAIL testElementAttribute(videoElement, "webkitanimationstart") should be target. Was script: none; content: target.
-FAIL testElementAttribute(videoElement, "webkitkeyadded") should be target. Was script: target; content: none.
-FAIL testElementAttribute(videoElement, "webkitkeyerror") should be target. Was script: target; content: none.
-FAIL testElementAttribute(videoElement, "webkitkeymessage") should be target. Was script: target; content: none.
+FAIL testElementAttribute(videoElement, "webkitkeyadded") should be target. Was none.
+FAIL testElementAttribute(videoElement, "webkitkeyerror") should be target. Was none.
+FAIL testElementAttribute(videoElement, "webkitkeymessage") should be target. Was none.
 FAIL testElementAttribute(videoElement, "webkitpresentationmodechanged") should be target. Was none.
 FAIL testElementAttribute(videoElement, "webkittransitionend") should be target. Was script: none; content: target.
 PASS testElementAttribute(videoElement, "wheel") is "target"
Comment 6 Brent Fulgham 2015-03-03 17:55:36 PST
I landed a Windows baseline in r180975. Let me know if we should track down the cause of the handful of differences in the output.
Comment 7 Darin Adler 2015-03-04 14:33:21 PST
My strategy was to leave out events that were different on different platforms. It looks like keyadded, keyerror, and keymessage are feature-specific and the feature is not turned on for Windows.

The preferred fix for now would be to remove those three events from the test and put them into the section below listing events that are platform specific that we might want to test one day.

Then we could remove the Windows-specific baseline.
Comment 8 Lucas Forschler 2019-02-06 09:03:09 PST
Mass moving XML DOM bugs to the "DOM" Component.