Bug 142181 - REGRESSION: fast/css/acid2-pixel.html and http/tests/misc/acid2-pixel.html became flaky
Summary: REGRESSION: fast/css/acid2-pixel.html and http/tests/misc/acid2-pixel.html be...
Status: RESOLVED DUPLICATE of bug 142249
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Normal
Assignee: Said Abou-Hallawa
URL: http://webkit-test-results.appspot.co...
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-02 10:58 PST by Alexey Proskuryakov
Modified: 2015-03-03 17:01 PST (History)
8 users (show)

See Also:


Attachments
Patch (2.80 KB, patch)
2015-03-02 19:24 PST, Said Abou-Hallawa
koivisto: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2015-03-02 10:58:17 PST
These tests became flaky on February 26th. First recorded failure in 180720, although the actual culprit could be substantially earlier.

 layer at (84,144) size 144x24
   RenderBlock (positioned) {DIV} at (48,72) size 144x24 [bgcolor=#FF0000]
     RenderBlock {DIV} at (0,0) size 144x0
-      RenderInline {OBJECT} at (0,0) size 131x14
-        RenderInline {OBJECT} at (0,0) size 131x14
-          RenderImage {OBJECT} at (13,0) size 131x24 [border: none (12px solid #000000) none]
+      RenderInline {OBJECT} at (0,0) size 35x14
+        RenderInline {OBJECT} at (0,0) size 35x14
+          RenderImage {OBJECT} at (109,24) size 35x0 [border: none (12px solid #000000) none]
     RenderBlock (floating) {DIV} at (0,0) size 144x24 [border: none (12px solid #FF0000) none (12px solid #000000)]
     RenderBlock {DIV} at (0,0) size 144x24 [border: none (24px solid #FFFF00)]
 layer at (84,216) size 144x24
Comment 1 Simon Fraser (smfr) 2015-03-02 11:00:51 PST
Possibly caused by
Comment 2 Simon Fraser (smfr) 2015-03-02 11:17:40 PST
I was thinking of http://trac.webkit.org/changeset/180683
Comment 3 Alexey Proskuryakov 2015-03-02 11:23:33 PST
Should I try rolling it out to confirm?
Comment 4 Alexey Proskuryakov 2015-03-02 12:38:39 PST
I tested locally. Got a flaky failure with r180683, not failure with r180682.

run-webkit-tests LayoutTests/fast/css/acid2-pixel.html --repeat 1000 -f --child-processes=50
Comment 5 Said Abou-Hallawa 2015-03-02 19:24:08 PST
Created attachment 247736 [details]
Patch
Comment 6 Simon Fraser (smfr) 2015-03-03 12:20:53 PST
Comment on attachment 247736 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=247736&action=review

> Source/WebCore/ChangeLog:13
> +        calls. In a very rare case, the layout does not finish reconstructing the
> +        render tree when the test runner dumps it. This introduced flakiness in

We should fix DRT and WTR to update style before the final layout.
Comment 7 Antti Koivisto 2015-03-03 12:23:10 PST
Comment on attachment 247736 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=247736&action=review

> Source/WebCore/ChangeLog:14
> +        calls. In a very rare case, the layout does not finish reconstructing the
> +        render tree when the test runner dumps it. This introduced flakiness in
> +        this test.

What case?

> Source/WebCore/html/HTMLObjectElement.cpp:140
>      clearUseFallbackContent();
> -    setNeedsStyleRecalc(SyntheticStyleChange);
> +    setNeedsStyleRecalc(ReconstructRenderTree);

This feels like papering over the actual problem.
Comment 8 Alexey Proskuryakov 2015-03-03 17:01:06 PST
Said asked me to roll out the offending patch for now.

*** This bug has been marked as a duplicate of bug 142249 ***