Bug 142105 - Add a "block-cookies" rule to the user content filter
Summary: Add a "block-cookies" rule to the user content filter
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Brady Eidson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-27 14:31 PST by Brady Eidson
Modified: 2015-02-27 14:50 PST (History)
3 users (show)

See Also:


Attachments
Patch v1 (13.22 KB, patch)
2015-02-27 14:33 PST, Brady Eidson
achristensen: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brady Eidson 2015-02-27 14:31:32 PST
Add a "block-cookies" rule to the user content filter
Comment 1 Brady Eidson 2015-02-27 14:33:02 PST
Created attachment 247553 [details]
Patch v1
Comment 2 Alex Christensen 2015-02-27 14:42:53 PST
Comment on attachment 247553 [details]
Patch v1

View in context: https://bugs.webkit.org/attachment.cgi?id=247553&action=review

This seems ok, except the ContentFilterAction enum, which could evolve into something completely different.  I have a few questions, though:

> Source/WebCore/contentextensions/ContentExtensionsManager.cpp:101
>      else if (actionType != "block" && actionType != "") {

I think this should just be else.

> Source/WebCore/page/UserContentController.h:52
> +enum class ContentFilterAction {

This will eventually be an index into a data structure I'll make.

> Source/WebCore/page/UserContentController.h:53
> +    Load,

I think Load should just be the absence of Block in the returned vector of actionsForURL

> Source/WebCore/page/UserContentController.h:94
> +    ContentFilterAction actionForURL(const URL&);

Will there only be one?  Should we return a vector of actions?
Comment 3 Alex Christensen 2015-02-27 14:48:57 PST
Comment on attachment 247553 [details]
Patch v1

Ok.  We'll change these things later.
Comment 4 Brady Eidson 2015-02-27 14:50:45 PST
http://trac.webkit.org/changeset/180783