Bug 141851 - Get rid of JSNameScope::m_type
Summary: Get rid of JSNameScope::m_type
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Filip Pizlo
URL:
Keywords:
Depends on:
Blocks: 141174 141850
  Show dependency treegraph
 
Reported: 2015-02-20 12:47 PST by Filip Pizlo
Modified: 2015-02-20 16:14 PST (History)
12 users (show)

See Also:


Attachments
the patch (34.43 KB, patch)
2015-02-20 14:17 PST, Filip Pizlo
no flags Details | Formatted Diff | Diff
the patch (37.20 KB, patch)
2015-02-20 14:33 PST, Filip Pizlo
ggaren: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Pizlo 2015-02-20 12:47:09 PST
The type can be described using different JSNameScope subclasses.  Then the flag is essentially conveyed using ClassInfo.
Comment 1 Filip Pizlo 2015-02-20 14:17:10 PST
Created attachment 247001 [details]
the patch
Comment 2 WebKit Commit Bot 2015-02-20 14:19:57 PST
Attachment 247001 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/runtime/JSNameScope.h:52:  The parameter name "vm" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/runtime/JSNameScope.h:52:  The parameter name "globalObject" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/runtime/JSNameScope.h:52:  The parameter name "identifier" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/runtime/JSNameScope.h:52:  The parameter name "value" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/runtime/JSNameScope.h:52:  The parameter name "type" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 5 in 17 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Filip Pizlo 2015-02-20 14:20:46 PST
(In reply to comment #2)
> Attachment 247001 [details] did not pass style-queue:
> 
> 
> ERROR: Source/JavaScriptCore/runtime/JSNameScope.h:52:  The parameter name
> "vm" adds no information, so it should be removed. 
> [readability/parameter_name] [5]
> ERROR: Source/JavaScriptCore/runtime/JSNameScope.h:52:  The parameter name
> "globalObject" adds no information, so it should be removed. 
> [readability/parameter_name] [5]
> ERROR: Source/JavaScriptCore/runtime/JSNameScope.h:52:  The parameter name
> "identifier" adds no information, so it should be removed. 
> [readability/parameter_name] [5]
> ERROR: Source/JavaScriptCore/runtime/JSNameScope.h:52:  The parameter name
> "value" adds no information, so it should be removed. 
> [readability/parameter_name] [5]
> ERROR: Source/JavaScriptCore/runtime/JSNameScope.h:52:  The parameter name
> "type" adds no information, so it should be removed. 
> [readability/parameter_name] [5]
> Total errors found: 5 in 17 files

Fixed locally.

> 
> 
> If any of these errors are false positives, please file a bug against
> check-webkit-style.
Comment 4 Filip Pizlo 2015-02-20 14:33:18 PST
Created attachment 247005 [details]
the patch

Fixes.
Comment 5 Geoffrey Garen 2015-02-20 14:34:42 PST
Comment on attachment 247005 [details]
the patch

r=me
Comment 6 Filip Pizlo 2015-02-20 14:55:22 PST
Landed in http://trac.webkit.org/changeset/180460
Comment 7 Filip Pizlo 2015-02-20 14:57:31 PST
gcc build fix in http://trac.webkit.org/changeset/180461