Bug 141062 - REGRESSION(r179357): Suspect this caused WebGL tests to start flaking (Requested by kling on #webkit).
Summary: REGRESSION(r179357): Suspect this caused WebGL tests to start flaking (Reques...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Commit Bot
URL:
Keywords:
Depends on:
Blocks: 140660
  Show dependency treegraph
 
Reported: 2015-01-29 17:26 PST by WebKit Commit Bot
Modified: 2015-01-29 22:51 PST (History)
4 users (show)

See Also:


Attachments
ROLLOUT of r179357 (140.77 KB, patch)
2015-01-29 17:26 PST, WebKit Commit Bot
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Commit Bot 2015-01-29 17:26:17 PST
http://trac.webkit.org/changeset/179357 broke the build:
Suspect this caused WebGL tests to start flaking (Requested by kling on #webkit).

This is an automatic bug report generated by webkitbot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests fail.
Comment 1 WebKit Commit Bot 2015-01-29 17:26:49 PST
Created attachment 245676 [details]
ROLLOUT of r179357

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Filip Pizlo 2015-01-29 18:08:14 PST
Can you explain why r179357 is being blamed for the flakes?
Comment 3 Andreas Kling 2015-01-29 18:22:19 PST
(In reply to comment #2)
> Can you explain why r179357 is being blamed for the flakes?

Looky:

https://build.webkit.org/builders/Apple%20Mavericks%20Debug%20WK2%20%28Tests%29?numbuilds=50

Some WebGL tests have either failed or flaked on every run since 179357.
Comment 4 Andreas Kling 2015-01-29 20:28:38 PST
Comment on attachment 245676 [details]
ROLLOUT of r179357

Clearing flags on attachment: 245676

Committed r179392: <http://trac.webkit.org/changeset/179392>
Comment 5 Andreas Kling 2015-01-29 20:28:44 PST
All reviewed patches have been landed.  Closing bug.
Comment 6 Chris Dumez 2015-01-29 22:51:31 PST
Interestingly, inspector/css/selector-specificity.html crashed on the bots after this roll out (it may be a flake):

https://build.webkit.org/results/Apple%20Mavericks%20Release%20WK2%20(Tests)/r179392%20(11150)/results.html
https://build.webkit.org/results/Apple%20Yosemite%20Debug%20WK1%20(Tests)/r179392%20(1911)/results.html