Bug 14092 - Webkit 522.11 Slows message rendering in ichat & Adium
Summary: Webkit 522.11 Slows message rendering in ichat & Adium
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 14158 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-06-12 09:30 PDT by Adam Williams
Modified: 2017-11-07 09:06 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Williams 2007-06-12 09:30:01 PDT
In ichat and Adium:
there may be a delay when a message is entered before it comes on screen. Sometimes it's a few seconds before it appears. Behavior is exactly the same in both apps with new webkit installed by Safari 3. have also noticed parsing errors appearing in console with messages containing converted characters to html table equivalents

2007-06-11 20:12:48.072 iChatAgent[597] WARNING: Did not find closing semicolon
in HTML string: i said "so did you hear about new leopard beta yet??"
Comment 1 Alexander Romanovich 2007-06-12 10:01:33 PDT
I have found that by hitting return a second time forces the delay to end and the message to appear immediately.
Comment 2 Adam Williams 2007-06-12 11:10:20 PDT
Thanks  Alexander Romanovich you are correct I confirm that as well.
Comment 3 Gibbons Burke 2007-06-12 17:16:57 PDT
I am experiencing this problem as well. I uninstalled Safari 3 beta and the problem cleared up. Re-installed Safari beta and the problem reappears.

It doesn't happen every time, but when I hit return to send a message, a cloud appears next to my picture in the message transcript part of the window with (...} as if I'm still typing a message. I can hit any key and the message gets sent. Delete, return - all of them prompt the message to complete and be sent.

Comment 4 Brady Eidson 2007-06-12 22:26:45 PDT
Interestingly - in iChat at least - the message *is* sent when you hit enter the first time (you can confirm this with an account on another machine in the same room) - it's just not visibly updated as such locally.

This is in radar at <rdar://problem/5266289>
Comment 5 Timothy Hatcher 2007-06-19 10:59:30 PDT
*** Bug 14158 has been marked as a duplicate of this bug. ***
Comment 6 Adam Williams 2007-06-22 22:50:55 PDT
I can confirm that safari 3.0.2 and webkit 522.12 has fixed this problem. Provided everyone can confirm this I think it's safe to mark as fixed. :)
Comment 7 David Kilzer (:ddkilzer) 2007-06-23 11:30:04 PDT
Radar is closed as fixed too.

Comment 8 Darin Adler 2017-11-07 09:06:49 PST
*** Bug 4363 has been marked as a duplicate of this bug. ***