Bug 140827 - Layout Test http/tests/media/track-in-band-hls-metadata.html is flaky
Summary: Layout Test http/tests/media/track-in-band-hls-metadata.html is flaky
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Jer Noble
URL:
Keywords: InRadar
: 140022 140831 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-23 09:37 PST by Jer Noble
Modified: 2019-11-05 07:01 PST (History)
4 users (show)

See Also:


Attachments
Patch (1.93 KB, patch)
2015-01-23 09:40 PST, Jer Noble
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jer Noble 2015-01-23 09:37:09 PST
The following layout test is flaky on Apple Yosemite Debug WK1

http/tests/media/track-in-band-hls-metadata.html

Probable cause:

NULL pointer dereference in MediaPlayerPrivateAVFoundationObjC::metadataDidArrive().
Comment 1 Jer Noble 2015-01-23 09:40:18 PST
Created attachment 245231 [details]
Patch
Comment 2 WebKit Commit Bot 2015-01-23 10:27:33 PST
Comment on attachment 245231 [details]
Patch

Clearing flags on attachment: 245231

Committed r179010: <http://trac.webkit.org/changeset/179010>
Comment 3 WebKit Commit Bot 2015-01-23 10:27:35 PST
All reviewed patches have been landed.  Closing bug.
Comment 4 Tim Horton 2015-01-23 11:17:12 PST
*** Bug 140831 has been marked as a duplicate of this bug. ***
Comment 5 David Kilzer (:ddkilzer) 2015-05-14 08:58:12 PDT
<rdar://problem/20919573>
Comment 6 David Kilzer (:ddkilzer) 2015-05-14 08:58:46 PDT
This was also a source of crashes in the WebContent process at:
WebCore::InbandMetadataTextTrackPrivateAVF::updatePendingCueEndTimes()
Comment 7 Eric Carlson 2019-11-05 07:01:48 PST
*** Bug 140022 has been marked as a duplicate of this bug. ***